diff mbox series

[bug#61078,4/4] gnu: Rename 'samba/fixed' to 'samba/pinned'.

Message ID 20230126164347.2462817-4-zimon.toutoune@gmail.com
State New
Headers show
Series Rename '/fixed' by '/pinned' | expand

Commit Message

Simon Tournier Jan. 26, 2023, 4:43 p.m. UTC
* gnu/packages/samba.scm: Rename variable 'samba/fixed' to 'samba/pinned' and
'samba/fixed-patched' to 'samba/fixed'.
* gnu/packages/gnome.scm (libsoup-minimal)[inputs]: Replace 'samba/fixed' with
'samba/pinned'.
---
 gnu/packages/gnome.scm |  2 +-
 gnu/packages/samba.scm | 10 +++++-----
 2 files changed, 6 insertions(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 10945ff457..9d79055289 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5190,7 +5190,7 @@  (define-public libsoup-minimal
            sqlite
            zlib))
     (inputs
-     (list mit-krb5 samba/fixed))     ; For ntlm_auth support
+     (list mit-krb5 samba/pinned))     ; For ntlm_auth support
     (home-page "https://wiki.gnome.org/Projects/libsoup")
     (synopsis "GLib-based HTTP Library")
     (description
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 00442d9645..da103ed839 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -275,14 +275,14 @@  (define-public samba
 Desktops into Active Directory environments using the winbind daemon.")
     (license license:gpl3+)))
 
-;;; FIXME: Invert inheritance relationship; the "fixed" package shouldn't be
+;;; FIXME: Invert inheritance relationship; the "pinned" package shouldn't be
 ;;; susceptible to changes in the free one.
-(define-public samba/fixed
+(define-public samba/pinned
   ;; Version that rarely changes, depended on by libsoup.
   (hidden-package
    (package
      (inherit samba)
-     (replacement samba/fixed-patched)
+     (replacement samba/fixed)
      (version "4.15.3")
      (source
       (origin
@@ -306,9 +306,9 @@  (define-public samba/fixed
             libxslt
             libxml2)))))
 
-(define-public samba/fixed-patched
+(define-public samba/fixed
   (package
-    (inherit samba/fixed)
+    (inherit samba/pinned)
     ;; This is 4.15.13, but we need to trim the store file name to have
     ;; the same length as the one we are grafting above.
     (version "4.15.A")