diff mbox series

[bug#61064] gnu: gnutls: Update to 3.7.8.

Message ID 20230125185518.12652-1-jackhill@jackhill.us
State New
Headers show
Series [bug#61064] gnu: gnutls: Update to 3.7.8. | expand

Commit Message

Jack Hill Jan. 25, 2023, 6:55 p.m. UTC
* gnu/packages/tls.scm (gnutls-latest): Update to 3.7.8.
---

I test build this on Linux x86_64, and was able to use guile-gnutls with
this version. The list reported by `guix refresh -l` wasn't working for
me, so I didn't rebuild all the packages. Upstream claims taht there are
"No changes [ABI or API] since last version," so I think it's pretty
safe.

Release notes: https://lists.gnupg.org/pipermail/gnutls-help/2022-September/004765.html

 gnu/packages/tls.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Jack Hill Jan. 5, 2024, 7:20 p.m. UTC | #1
On Fri, 5 Jan 2024, GNU bug Tracking System wrote:

> This is an automatic notification regarding your bug report
> #61064: [PATCH] gnu: gnutls: Update to 3.7.8.,
> which was filed against the guix-patches package.
>
> Thank you for your report, which has now been closed.
> You can view the full report at
> https://debbugs.gnu.org/cgi/bugreport.cgi?bug=61064
>
> If you require further information, please followup to 61064@debbugs.gnu.org.

Hi Maxim,

Thanks for taking the time to clean up some old issues. However, Can you 
say a little bit more about what the thinking is on this one? I notice 
that we still have some packages (e.g. dino via glib-networking) that are 
still on gnutls-3.7. Is the idea tha it would be better to switch those 
over to 3.8 than update 3.7?

Thanks!
Jack
Maxim Cournoyer Jan. 5, 2024, 8:13 p.m. UTC | #2
Hi,

Jack Hill <jackhill@jackhill.us> writes:

> On Fri, 5 Jan 2024, GNU bug Tracking System wrote:
>
>> This is an automatic notification regarding your bug report
>> #61064: [PATCH] gnu: gnutls: Update to 3.7.8.,
>> which was filed against the guix-patches package.
>>
>> Thank you for your report, which has now been closed.
>> You can view the full report at
>> https://debbugs.gnu.org/cgi/bugreport.cgi?bug=61064
>>
>> If you require further information, please followup to 61064@debbugs.gnu.org.
>
> Hi Maxim,
>
> Thanks for taking the time to clean up some old issues. However, Can
> you say a little bit more about what the thinking is on this one? I
> notice that we still have some packages (e.g. dino via
> glib-networking) that are still on gnutls-3.7. Is the idea tha it
> would be better to switch those over to 3.8 than update 3.7?

There's a single gnutls package, which is grafted with 3.8.2.  So any
updates to anterior versions are obsolete :-).
Jack Hill Jan. 6, 2024, 5:38 a.m. UTC | #3
On Fri, 5 Jan 2024, Maxim Cournoyer wrote:

> There's a single gnutls package, which is grafted with 3.8.2.  So any
> updates to anterior versions are obsolete :-).

Very good, thanks for the explanation. If only I had looked at the Guix 
source first (and pulled as well, thanks for the 3.8.2 update). Next time 
:)

Best,
Jack
diff mbox series

Patch

diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index bdac8a6e63..5dc9866077 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -335,7 +335,7 @@  (define-public gnutls
 (define-public gnutls-latest
   (package
     (inherit gnutls)
-    (version "3.7.7")
+    (version "3.7.8")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnupg/gnutls/v"
@@ -345,7 +345,7 @@  (define-public gnutls-latest
                                        "gnutls-cross.patch"))
               (sha256
                (base32
-                "01i1gl15k6qwvxmxx0by1mn9nlmcmym18wdpm7dn9awfsp8474dy"))))
+                "053ic7a9dcvzjx8pqjxn3022189i4f5klppfi9mgw3k7y2dd72n5"))))
 
     ;; Disable Guile bindings: they are now provided by Guile-GnuTLS.
     (inputs (modify-inputs (package-inputs gnutls)