diff mbox series

[bug#61056] gnu: Add jwm.

Message ID 20230125111514.5194-1-tumashu@163.com
State New
Headers show
Series [bug#61056] gnu: Add jwm. | expand

Commit Message

Feng Shu Jan. 25, 2023, 11:15 a.m. UTC
From: Feng Shu <tumashu@163.com>

* gnu/packages/wm.scm (jwm): New variable.
---
 gnu/packages/wm.scm | 62 +++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 62 insertions(+)

Comments

Feng Shu Jan. 27, 2023, 11:07 a.m. UTC | #1
from: https://github.com/joewing/jwm/issues/596

I know the newest version is 2.4.3 instead of 2.4.4

--
Feng Shu Feb. 13, 2023, 10:56 a.m. UTC | #2
Hello:

Please review v8 version of jwm/mjwm patch.

Thanks

--
Feng Shu Feb. 28, 2023, 10:04 p.m. UTC | #3
ping :-)
宋文武 March 6, 2023, 7:46 a.m. UTC | #4
Feng Shu <tumashu@163.com> writes:

> Hello:
>
> Please review v8 version of jwm/mjwm patch.
>
> Thanks

Hello, I have pushed jwm and mjwm with follow changes:

1. remove tango-icon-theme, mjwm, xterm from jwm's inputs.  see 2.

2. remove patch-example.jwmrc and install-tango-icon-files phases.
   I think those kind of customization better happend in ~/.jwmrc or
   a home service.
   
3. change libxrandr to libxrender for jwm, as the latter is actually
   used...

4. mjwm: remove '.' in synopsis, change license to 'license:gpl2+'.


What do you think of my changes in 1. and 2.?
宋文武 March 6, 2023, 8:04 a.m. UTC | #5
宋文武 <iyzsong@envs.net> writes:

> Feng Shu <tumashu@163.com> writes:
>
>> Hello:
>>
>> Please review v8 version of jwm/mjwm patch.
>>
>> Thanks
>
> Hello, I have pushed jwm and mjwm with follow changes:
Well, I haven't pushed due to other's updates, that's good.

>
> 1. remove tango-icon-theme, mjwm, xterm from jwm's inputs.  see 2.
>
> 2. remove patch-example.jwmrc and install-tango-icon-files phases.
>    I think those kind of customization better happend in ~/.jwmrc or
>    a home service.
>    
> 3. change libxrandr to libxrender for jwm, as the latter is actually
>    used...
>
> 4. mjwm: remove '.' in synopsis, change license to 'license:gpl2+'.
>
>
> What do you think of my changes in 1. and 2.?

My updated patches are replied to this issue.
Feng Shu March 6, 2023, 12:11 p.m. UTC | #6
宋文武 <iyzsong@envs.net> writes:

> Feng Shu <tumashu@163.com> writes:
>
>> Hello:
>>
>> Please review v8 version of jwm/mjwm patch.
>>
>> Thanks
>
> Hello, I have pushed jwm and mjwm with follow changes:
>
> 1. remove tango-icon-theme, mjwm, xterm from jwm's inputs.  see 2.
>
> 2. remove patch-example.jwmrc and install-tango-icon-files phases.
>    I think those kind of customization better happend in ~/.jwmrc or
>    a home service.
>    
> 3. change libxrandr to libxrender for jwm, as the latter is actually
>    used...
>
> 4. mjwm: remove '.' in synopsis, change license to 'license:gpl2+'.
>
>
> What do you think of my changes in 1. and 2.?

no problem.

--
宋文武 March 7, 2023, 1:08 a.m. UTC | #7
Feng Shu <tumashu@163.com> writes:

> 宋文武 <iyzsong@envs.net> writes:
>
>> Feng Shu <tumashu@163.com> writes:
>>
>>> Hello:
>>>
>>> Please review v8 version of jwm/mjwm patch.
>>>
>>> Thanks
>>
>> Hello, I have pushed jwm and mjwm with follow changes:
>>
>> 1. remove tango-icon-theme, mjwm, xterm from jwm's inputs.  see 2.
>>
>> 2. remove patch-example.jwmrc and install-tango-icon-files phases.
>>    I think those kind of customization better happend in ~/.jwmrc or
>>    a home service.
>>    
>> 3. change libxrandr to libxrender for jwm, as the latter is actually
>>    used...
>>
>> 4. mjwm: remove '.' in synopsis, change license to 'license:gpl2+'.
>>
>>
>> What do you think of my changes in 1. and 2.?
>
> no problem.

Pushed, thank you!
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index a860ed1f93..1fb2b46efc 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -108,6 +108,7 @@  (define-module (gnu packages wm)
   #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages fribidi)
   #:use-module (gnu packages gawk)
+  #:use-module (gnu packages gettext)
   #:use-module (gnu packages gl)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gperf)
@@ -2793,6 +2794,67 @@  (define-public hikari
 capabilities.  It is heavily inspired by the Calm Window manager(cwm).")
     (license license:bsd-2)))
 
+(define-public jwm
+  (package
+    (name "jwm")
+    (version "2.4.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/joewing/jwm")
+             (commit "4640d3b48ea64bd57e3cea63e4c4a9cd558e6142")))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0xwk54y8q12y3cvbgrjhda6g4jd5f57bvyasyb9qdbczzxfhvxqw"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list
+      #:tests? #f   ; no check target
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'install 'install-xsession
+            (lambda* (#:key outputs #:allow-other-keys)
+              (let* ((out (assoc-ref outputs "out"))
+                     (xsessions (string-append out "/share/xsessions")))
+                (mkdir-p xsessions)
+                (call-with-output-file
+                    (string-append xsessions "/jwm.desktop")
+                  (lambda (port)
+                    (format port "~
+                     [Desktop Entry]~@
+                     Name=jwm~@
+                     Comment=Joe's Window Manager~@
+                     Exec=~a/bin/jwm~@
+                     Type=XSession~%" out))))
+              #t)))))
+    (native-inputs
+     (list autoconf
+           automake
+           gettext-minimal
+           pkg-config))
+    (inputs
+     (list cairo
+           libjpeg-turbo
+           libpng
+           librsvg
+           libxext
+           libxinerama
+           libxmu
+           libxpm
+           libxrandr
+           libxt
+           pango))
+    (home-page "http://joewing.net/projects/jwm")
+    (synopsis "Joe's Window Manager")
+    (description
+     "JWM is a light-weight window manager for the X11 Window System.  it is
+written in C and uses only Xlib at a minimum.  Because of its small footprint,
+it makes a good window manager for older computers and less powerful systems,
+such as the Raspberry Pi, though it is perfectly capable of running on modern
+systems.")
+    (license license:expat)))
+
 (define-public devour
   (package
     (name "devour")