diff mbox series

[bug#61042,5/6] gnu: spice: Update to 0.15.1.

Message ID 20230124184825.21827-5-simon@netpanic.org
State New
Headers show
Series Upgrade spice packages | expand

Commit Message

Simon Streit Jan. 24, 2023, 6:48 p.m. UTC
* gnu/packages/spice.scm (spice): Update to 0.15.1.
  [inputs]: Add bash-minimal.
---
 gnu/packages/spice.scm | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
index 1f68b1309d..44080049c5 100644
--- a/gnu/packages/spice.scm
+++ b/gnu/packages/spice.scm
@@ -219,7 +219,7 @@  (define-public spice-gtk
 (define-public spice
   (package
     (name "spice")
-    (version "0.15.0")
+    (version "0.15.1")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -227,12 +227,13 @@  (define-public spice
                 "spice-server/spice-" version ".tar.bz2"))
               (sha256
                (base32
-                "1xd0xffw0g5vvwbq4ksmm3jjfq45f9dw20xpmi82g1fj9f7wy85k"))))
+                "0ym3n60gq0kzzknk5ir8ib09cxsak9hkv7mmgsyic69jmdkszadd"))))
     (build-system gnu-build-system)
     (propagated-inputs
       (list openssl-1.1 pixman spice-protocol))
     (inputs
-      (list cyrus-sasl
+      (list bash-minimal
+            cyrus-sasl
             glib
             libjpeg-turbo
             libcacard ; smartcard support
@@ -251,7 +252,6 @@  (define-public spice
       `(#:configure-flags
         '("--enable-lz4"
           "--enable-automated-tests")
-
         #:phases
         (modify-phases %standard-phases
           ;; XXX: Otherwise the server listen tests fails with
@@ -259,7 +259,6 @@  (define-public spice
           (add-before 'check 'set-XDG_CONFIG_HOME
             (lambda _
               (setenv "XDG_CONFIG_HOME" "/tmp"))))
-
         ;; Several tests appear to be opening the same sockets concurrently.
         #:parallel-tests? #f))
     (synopsis "Server implementation of the SPICE protocol")