diff mbox series

[bug#60970] gnu: mpdris2: Remove input latels and add inputs.

Message ID 20230120190709.25413-1-simon@netpanic.org
State New
Headers show
Series [bug#60970] gnu: mpdris2: Remove input latels and add inputs. | expand

Commit Message

Simon Streit Jan. 20, 2023, 7:07 p.m. UTC
* gnu/packages/mpd.scm (mpdris2)[inputs]: Remove labels.  Add bash-minimal and
python-mutagen.  [native-inputs]: Remove labels.
---
 gnu/packages/mpd.scm | 22 ++++++++++++----------
 1 file changed, 12 insertions(+), 10 deletions(-)

Comments

Nicolas Goaziou Feb. 23, 2023, 2:41 p.m. UTC | #1
Hello,

Simon Streit <simon@netpanic.org> writes:

> * gnu/packages/mpd.scm (mpdris2)[inputs]: Remove labels.  Add bash-minimal and
> python-mutagen.  [native-inputs]: Remove labels.

Thank you. I applied it and took the liberty to further improve package
style (using G-expressions, and using complete sentences in the
description).

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index 63163e09dc..7d6b05f99e 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -9,7 +9,7 @@ 
 ;;; Copyright © 2019 Evan Straw <evan.straw99@gmail.com>
 ;;; Copyright © 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2020 Lars-Dominik Braun <lars@6xq.net>
-;;; Copyright © 2020–2022 Simon Streit <simon@netpanic.org>
+;;; Copyright © 2020–2023 Simon Streit <simon@netpanic.org>
 ;;; Copyright © 2021 Noah Evans <noah@nevans.me>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -442,15 +442,17 @@  (define-public mpdris2
                (wrap-program (string-append out "/bin/mpDris2")
                  `("GUIX_PYTHONPATH" ":" prefix (,python-path)))
                #t))))))
-    (inputs
-     (list python-mpd2 python-dbus python-pygobject python))             ; Sets GUIX_PYTHONPATH.
-    ;; For bootstrapping.
-    (native-inputs
-     `(("autoconf" ,autoconf)
-       ("automake" ,automake)
-       ("gettext" ,gettext-minimal)
-       ("which" ,which)
-       ("intltool" ,intltool)))
+    (inputs (list bash-minimal
+                  python
+                  python-dbus
+                  python-mpd2
+                  python-mutagen
+                  python-pygobject))
+    (native-inputs (list autoconf
+                         automake
+                         gettext-minimal
+                         intltool
+                         which))
     (synopsis "MPRIS V2.1 support for MPD")
     (description "Client for the Music Player Daemon providing MPRIS 2
 support")