diff mbox series

[bug#60871] gnu: add timewarrior

Message ID 20230117041702.14099-1-trev@trevdev.ca
State New
Headers show
Series [bug#60871] gnu: add timewarrior | expand

Commit Message

Trevor Richards Jan. 17, 2023, 4:17 a.m. UTC
Signed-off-by: Trevor Richards <trev@trevdev.ca>
---
 gnu/packages/task-management.scm | 33 ++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

Comments

Trevor Richards Jan. 17, 2023, 5:48 a.m. UTC | #1
Beg your pardon(s), I forgot to add a couple of dependencies to the
module imports.
diff mbox series

Patch

diff --git a/gnu/packages/task-management.scm b/gnu/packages/task-management.scm
index c4f7f99049..d301699aa4 100644
--- a/gnu/packages/task-management.scm
+++ b/gnu/packages/task-management.scm
@@ -154,6 +154,39 @@  (define-public taskwarrior
 and querying data, exposing task data in multiple formats to other tools.")
     (license license:expat)))
 
+(define-public timewarrior
+  (package
+    (name "timewarrior")
+    (version "1.4.3")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/GothenburgBitFactory/timewarrior/"
+                    "releases/download/v"
+                    version
+                    "/timew-"
+                    version
+                    ".tar.gz"))
+              (sha256
+               (base32
+                "0lyaqzcg8np2fpsmih0hlkjxd3qbadc7khr24m1pq9lsdhq7xpy4"))))
+    (build-system cmake-build-system)
+    (inputs (list python ruby-asciidoctor bash-minimal))
+    (arguments
+     (list #:phases #~(modify-phases %standard-phases
+                        (add-after 'patch-source-shebangs 'patch-hardcoded-paths
+                          (lambda _
+                            (substitute* "src/commands/CMakeLists.txt"
+                              (("/bin/sh")
+                               (string-append #$(this-package-input
+                                                 "bash-minimal")
+                                              "/bin/sh"))))))))
+    (home-page "https://timewarrior.net")
+    (synopsis "A command line tool for tracking time")
+    (description "Timewarrior is Free and Open Source Software that tracks
+time from the command line.")
+    (license license:expat)))
+
 (define-public tasksh
   (package
     (name "tasksh")