diff mbox series

[bug#60835,v3,1/8] gnu: Add cl-variates.

Message ID 20230115215913.3930-1-jgart@dismail.de
State New
Headers show
Series [bug#60835,v3,1/8] gnu: Add cl-variates. | expand

Commit Message

jgart Jan. 15, 2023, 9:59 p.m. UTC
* gnu/packages/lisp-xyz.scm (cl-variates, ecl-cl-variates,
sbcl-cl-variates): New variables.

Sorry, I accidentally bunched an unrelated patch in v2. Here's v3.

all best,

jgart
---
 gnu/packages/lisp-xyz.scm | 35 ++++++++++++++++++++++++++++++++++-
 1 file changed, 34 insertions(+), 1 deletion(-)

Comments

Guillaume Le Vaillant Jan. 18, 2023, 1:08 p.m. UTC | #1
Hi,
The patches don't apply cleanly; it looks like they are based on
a custom branch (the sbcl-seria package at the end of the patches'
context is not in Guix).
Could you send an updated patch series rebased on the master branch?
Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 943d295c5d..35e10b3301 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -28,7 +28,7 @@ 
 ;;; Copyright © 2021 Cameron Chaparro <cameron@cameronchaparro.com>
 ;;; Copyright © 2021 Charles Jackson <charles.b.jackson@protonmail.com>
 ;;; Copyright © 2021, 2022 Foo Chuan Wei <chuanwei.foo@hotmail.com>
-;;; Copyright © 2021, 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2021, 2022, 2023 jgart <jgart@dismail.de>
 ;;; Copyright © 2021 Aleksandr Vityazev <avityazev@posteo.org>
 ;;; Copyright © 2021 Jacob MacDonald <jaccarmac@gmail.com>
 ;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
@@ -26644,6 +26644,39 @@  (define-public cl-smug
 (define-public ecl-smug
   (sbcl-package->ecl-package sbcl-smug))
 
+(define-public sbcl-cl-variates
+  (let ((commit "4e7548754d8a8731a42487fae31174db4bf36d47")
+        (revision "0"))
+    (package
+        (name "sbcl-cl-variates")
+        (version "0.9.0")
+        (source
+          (origin
+            (method git-fetch)
+            (uri (git-reference
+                  (url "https://gitlab.common-lisp.net/cl-variates/cl-variates")
+                  (commit commit)))
+            (file-name (git-file-name name version))
+            (sha256
+             (base32 "03wnvfi3yfflpvi0mr732r834msij4vrwdbgf6csh0b8kqxl47zn"))))
+        (build-system asdf-build-system/sbcl)
+        ;; USE-PACKAGE #<PACKAGE "CL-VARIATES"> causes name-conflicts in
+        ;; #<PACKAGE "CL-VARIATES-TEST"> between the following symbols:
+        ;; CL-VARIATES:RANDOM-ELEMENT, LIFT:RANDOM-ELEMENT
+        (arguments (list #:tests? #f))
+        (native-inputs (list sbcl-lift))
+        (home-page "https://gitlab.common-lisp.net/cl-variates/cl-variates")
+        (synopsis "Portable Common Lisp Random Number Generation")
+        (description "The variates package provides portable random number
+    generation as well as numerous distributions.")
+        (license license:expat))))
+
+(define-public cl-variates
+  (sbcl-package->cl-source-package sbcl-cl-variates))
+
+(define-public ecl-cl-variates
+  (sbcl-package->ecl-package sbcl-cl-variates))
+
 (define-public sbcl-seria
   (let ((commit "2bba04dc6abdc0b85a511cae9c460942e2ad305a")
         (revision "0"))