diff mbox series

[bug#60797] Update i3 and deprecate i3-gaps

Message ID 20230113233911.tz7hoviergbndrnc@blackbox
State New
Headers show
Series [bug#60797] Update i3 and deprecate i3-gaps | expand

Commit Message

Gabriel Wicki Jan. 13, 2023, 11:39 p.m. UTC
Hello!

i3-wm has been updated and i3-gaps has been merged into mainline i3.
The following patch reflects these circumstances.  Thanks for merging,

g


P.S. The diff is this giant because `guix style` wanted it to be.
I'm not 100% sure if this is really appropriate.

From e596cbb4ce663efa3239f83edaba24e0e0da9e4f Mon Sep 17 00:00:00 2001
From: Gabriel Wicki <gabriel@erlikon.ch>
Date: Sat, 14 Jan 2023 00:00:18 +0100
Subject: [PATCH] gnu: i3: Update to 4.22

* gnu/packages/wm.scm (i3): Update to 4.22. (i3-gaps): Deprecate package.
---
 gnu/packages/wm.scm | 127 +++++++++++++++++---------------------------
 1 file changed, 50 insertions(+), 77 deletions(-)

Comments

Marcel van der Boom Jan. 14, 2023, 10:06 a.m. UTC | #1
See also: https://issues.guix.gnu.org/60755
宋文武 Jan. 28, 2023, 5:55 a.m. UTC | #2
Gabriel Wicki <gabriel@erlikon.ch> writes:

> Hello!
>
> i3-wm has been updated and i3-gaps has been merged into mainline i3.
> The following patch reflects these circumstances.  Thanks for merging,

Hello, I merged the simple i3 update patch and deprecated i3-gaps in this
patch.  Thank you!
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index a13467663e..6b97481a37 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -60,6 +60,7 @@ 
 ;;; Copyright © 2022 Fredrik Salomonsson <plattfot@posteo.net>
 ;;; Copyright © 2022 ( <paren@disroot.org>
 ;;; Copyright © 2022 zamfofex <zamfofex@twdb.moe>
+;;; Copyright © 2023 Gabriel Wicki <gabriel@erlikon.ch>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -309,58 +310,60 @@  (define-public i3status
 (define-public i3-wm
   (package
     (name "i3-wm")
-    (version "4.20.1")
+    (version "4.22")
     (source (origin
               (method url-fetch)
-              (uri (string-append "https://i3wm.org/downloads/i3-"
-                                  version ".tar.xz"))
+              (uri (string-append "https://i3wm.org/downloads/i3-" version
+                                  ".tar.xz"))
               (sha256
                (base32
-                "1rpwdgykcvmrmdz244f0wm7446ih1dcw8rlc1hm1c7cc42pyrq93"))))
+                "0jrya4rhh46sivlmqaqc4n9abpp1yn1ajhi616gn75cxwl8rjqr8"))))
     (build-system meson-build-system)
     (arguments
-     `(;; The test suite requires the unpackaged Xephyr X server.
-       #:tests? #f
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'install 'patch-session-file
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (i3 (string-append out "/bin/i3"))
-                    (i3-with-shmlog (string-append out "/bin/i3-with-shmlog")))
-               (substitute* (string-append out "/share/xsessions/i3.desktop")
-                 (("Exec=i3") (string-append "Exec=" i3)))
-               (substitute* (string-append out "/share/xsessions/i3-with-shmlog.desktop")
-                 (("Exec=i3-with-shmlog") (string-append "Exec=" i3-with-shmlog)))
-               #t))))))
-    (inputs
-     (list libxcb
-           xcb-util
-           xcb-util-cursor
-           xcb-util-keysyms
-           xcb-util-wm
-           xcb-util-xrm
-           libxkbcommon
-           libev
-           yajl
-           xmlto
-           perl-pod-simple
-           libx11
-           pcre
-           startup-notification
-           pango
-           cairo))
-    (native-inputs
-     (list which
-           perl
-           pkg-config
-           asciidoc
-           ;; For building the documentation.
-           libxml2
-           docbook-xsl))
+     `( ;The test suite requires the unpackaged Xephyr X server.
+        #:tests? #f
+       #:phases (modify-phases %standard-phases
+                  (add-after 'install 'patch-session-file
+                    (lambda* (#:key outputs #:allow-other-keys)
+                      (let* ((out (assoc-ref outputs "out"))
+                             (i3 (string-append out "/bin/i3"))
+                             (i3-with-shmlog (string-append out
+                                              "/bin/i3-with-shmlog")))
+                        (substitute* (string-append out
+                                      "/share/xsessions/i3.desktop")
+                          (("Exec=i3")
+                           (string-append "Exec=" i3)))
+                        (substitute* (string-append out
+                                      "/share/xsessions/i3-with-shmlog.desktop")
+                          (("Exec=i3-with-shmlog")
+                           (string-append "Exec=" i3-with-shmlog))) #t))))))
+    (inputs (list libxcb
+                  xcb-util
+                  xcb-util-cursor
+                  xcb-util-keysyms
+                  xcb-util-wm
+                  xcb-util-xrm
+                  libxkbcommon
+                  libev
+                  yajl
+                  xmlto
+                  perl-pod-simple
+                  libx11
+                  pcre2
+                  startup-notification
+                  pango
+                  cairo))
+    (native-inputs (list which
+                         perl
+                         pkg-config
+                         asciidoc
+                         ;; For building the documentation.
+                         libxml2
+                         docbook-xsl))
     (home-page "https://i3wm.org/")
     (synopsis "Tiling window manager")
-    (description "i3 is a tiling X11 window manager that dynamically manages
+    (description
+     "i3 is a tiling X11 window manager that dynamically manages
 tiled, stacked, and tabbed window layouts.
 
 i3 primarily targets advanced users.  Windows are managed manually and organised
@@ -369,42 +372,12 @@  (define-public i3-wm
 
 i3 uses a plain-text configuration file, and can be extended and controlled from
 many programming languages.")
-    (properties
-     `((upstream-name . "i3")
-       (release-monitoring-url . "https://i3wm.org/downloads")))
+    (properties `((upstream-name . "i3")
+                  (release-monitoring-url . "https://i3wm.org/downloads")))
     (license license:bsd-3)))
 
 (define-public i3-gaps
-  (package
-    (inherit i3-wm)
-    (name "i3-gaps")
-    (version "4.20.1")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/Airblader/i3")
-                    (commit version)))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "0g0qmv2gpv9qbhj9h5f4c4vfs6ndzq2rblgx9md85iharwp5sbb9"))))
-    (home-page "https://github.com/Airblader/i3")
-    (synopsis "Tiling window manager with gaps")
-    (description
-     "i3-gaps is a fork of i3wm, a tiling window manager
-for X11.  It is kept up to date with upstream, adding a few additional
-features such as gaps between windows.
-
-i3 is a tiling X11 window manager that dynamically manages tiled, stacked,
-and tabbed window layouts.
-
-i3 primarily targets advanced users.  Windows are managed manually and
-organised inside containers, which can be split vertically or horizontally,
-and optionally resized.
-
-i3 uses a plain-text configuration file, and can be extended and controlled
-from many programming languages.")
-    (license license:bsd-3)))
+  (deprecated-package "i3-gaps" i3-wm))
 
 (define-public i3lock
   (package