diff mbox series

[bug#60789] gnu: moreutils: Fix library path.

Message ID 20230113205801.1188087-1-code@greghogan.com
State New
Headers show
Series [bug#60789] gnu: moreutils: Fix library path. | expand

Commit Message

Greg Hogan Jan. 13, 2023, 8:58 p.m. UTC
Fix for the following error.

$ guix shell --container moreutils -- chronic ls
Can't locate IPC/Run.pm in @INC (you may need to install the IPC::Run module) (@INC contains: /gnu/store/hy6abswwv4d89zp464fw52z65fkzr7h5-perl-5.34.0/lib/perl5/site_perl/5.34.0/x86_64-linux-thread-multi /gnu/store/hy6abswwv4d89zp464fw52z65fkzr7h5-perl-5.34.0/lib/perl5/site_perl/5.34.0 /gnu/store/hy6abswwv4d89zp464fw52z65fkzr7h5-perl-5.34.0/lib/perl5/5.34.0/x86_64-linux-thread-multi /gnu/store/hy6abswwv4d89zp464fw52z65fkzr7h5-perl-5.34.0/lib/perl5/5.34.0) at /gnu/store/r7kzz76arp9h480h2rnpdg21yzd6pyk2-profile/bin/chronic line 57.
BEGIN failed--compilation aborted at /gnu/store/r7kzz76arp9h480h2rnpdg21yzd6pyk2-profile/bin/chronic line 57.

* gnu/packages/moreutils.scm: Set Perl library path for all scripts.
[inputs]: Add perl-ipc-run.
---
 gnu/packages/moreutils.scm | 9 ++++++---
 1 file changed, 6 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/moreutils.scm b/gnu/packages/moreutils.scm
index 5c9560530b..4b0b617bde 100644
--- a/gnu/packages/moreutils.scm
+++ b/gnu/packages/moreutils.scm
@@ -49,9 +49,11 @@  (define-public moreutils
            #~(modify-phases %standard-phases
                (add-after 'install 'wrap-program
                  (lambda _
-                   (wrap-program
-                       (string-append #$output "/bin/ts")
-                     `("PERL5LIB" ":" prefix (,(getenv "PERL5LIB"))))))
+                   (for-each
+                     (lambda (script)
+                       (wrap-program script
+                         `("PERL5LIB" ":" prefix (,(getenv "PERL5LIB")))))
+                     (find-files (string-append #$output "/bin")))))
                (delete 'configure))     ; no configure script
            #:make-flags
            #~(list (string-append "PREFIX=" #$output)
@@ -63,6 +65,7 @@  (define-public moreutils
                    (string-append "CC=" #$(cc-for-target)))))
     (inputs
      (list perl
+           perl-ipc-run
            perl-timedate
            perl-time-duration))
     ;; For building the manual pages.