diff mbox series

[bug#60745,1/1] gnu: Add python-virtualenv-clone * gnu/packages/python-xyz.scm (python-virtualenv-clone): New variable.

Message ID 20230111223929.1002766-1-steve@futurile.net
State New
Headers show
Series [bug#60745,1/1] gnu: Add python-virtualenv-clone * gnu/packages/python-xyz.scm (python-virtualenv-clone): New variable. | expand

Commit Message

Steve George Jan. 11, 2023, 10:39 p.m. UTC
---
 gnu/packages/python-xyz.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)


base-commit: 5f7ce22201c25b0a73dae253b8759fa245c65799

Comments

Christopher Baines Feb. 17, 2023, 3:57 p.m. UTC | #1
Thanks Steve, I've pushed this to master as
fc36ea0a0a40c618ee3488d8432ebb6d27b56fa3.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 32d826d3c5..1e38f0315a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4282,6 +4282,40 @@  (define-public python-crossenv
 work on your part.")
     (license license:expat)))
 
+(define-public python-virtualenv-clone
+  (package
+    (name "python-virtualenv-clone")
+    (version "0.5.7")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/edwardgeorge/virtualenv-clone")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0p0d1y3axvjfnxlgwjx2374gikc8bmc82g0m7yashihbikh7pcxa"))))
+    (build-system python-build-system)
+    (arguments
+     (list #:phases #~(modify-phases %standard-phases
+                        (replace 'check
+                          (lambda* (#:key tests? #:allow-other-keys)
+                            (when tests?
+                              (delete-file "tox.ini")
+                              (invoke "pytest" "-vvv" "tests")))))))
+    (native-inputs (list python-pytest
+                         python-tox
+                         python-virtualenv
+                         python-coverage
+                         python-wheel
+                         python-tomli
+                         python-hypothesis))
+    (home-page "https://github.com/edwardgeorge/virtualenv-clone")
+    (synopsis "Clone a non-relocatable virtualenv cleanly")
+    (description
+     "Clone non-relocatable virtualenvs without breaking site-packages.")
+    (license license:expat)))
+
 (define-public python-uc-micro-py
   (package
     (name "python-uc-micro-py")