diff mbox series

[bug#60224,v4,04/12] gnu: make-u-boot-package: Allow disabling cross-compilation.

Message ID 20230111204433.15305-4-maxim.cournoyer@gmail.com
State New
Headers show
Series [bug#60224,v4,01/12] gnu: make-u-boot-package: Add a u-boot argument and use gexps. | expand

Commit Message

Maxim Cournoyer Jan. 11, 2023, 8:44 p.m. UTC
* gnu/packages/bootloaders.scm (make-u-boot-package): Accept #f for the
TRIPLET argument to disable cross-compilation.  Update doc.
---

(no changes since v1)

 gnu/packages/bootloaders.scm | 12 +++++++-----
 1 file changed, 7 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 4a27a36d78..e48b55018b 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -864,14 +864,16 @@  (define*-public (make-u-boot-package board triplet
                                      (u-boot u-boot))
   "Return a U-Boot package for BOARD cross-compiled for TRIPLET with the
 optional DEFCONFIG file and optional configuration changes from CONFIGS.
-NAME-SUFFIX is appended to the package name, while APPEND-DESCRIPTION is
-appended to the package description.  U-BOOT can be used when a fork or a
-different version of U-Boot must be used."
+TRIPLET may also be set to #f to disable cross-compilation.  NAME-SUFFIX is
+appended to the package name, while APPEND-DESCRIPTION is appended to the
+package description.  U-BOOT can be used when a fork or a different version of
+U-Boot must be used."
   (let ((native-build? (lambda ()
                          ;; Note: %current-system is a *triplet*, unlike its
                          ;; name would suggest.
-                         (string=? (%current-system)
-                                   (gnu-triplet->nix-system triplet)))))
+                         (or (not triplet) ;disable cross-compilation
+                             (string=? (%current-system)
+                                       (gnu-triplet->nix-system triplet))))))
     (package
       (inherit u-boot)
       (name (string-append "u-boot-"