diff mbox series

[bug#60732] New package: python-scapy

Message ID 20230111163659.wudbizhylifjt3nj@blackbox
State New
Headers show
Series [bug#60732] New package: python-scapy | expand

Commit Message

Gabriel Wicki Jan. 11, 2023, 4:36 p.m. UTC
Hi!

I had time to pack some more software for our favorite distro: Python
Scapy.  It's a powerful tool which allows the creation and inspection
of ethernet frames and other network traffic packets from within Python.


From f2ca7968afdc5013d78f38e47bf9bfc34af2baa0 Mon Sep 17 00:00:00 2001
From: Gabriel Wicki <gabriel@erlikon.ch>
Date: Mon, 9 Jan 2023 16:06:20 +0100
Subject: [PATCH] gnu: Add package python-scapy

* gnu/packages/python-xyz.scm (python-scapy):  New variable.
---
 gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

Andreas Enge March 11, 2023, 10:24 p.m. UTC | #1
Hello Gabriel,

apologies for not coming back to you. I was a bit torn about the
dependencies, since we tend to package software as "completely" as
possible. Here however the optional dependencies are quite heavy,
and python-pycrypto is outdated and unmaintained and should not be
used anymore. So in the end I opted to leave them out, if someone feels
the need, we can add them to the package, or indeed as you said they
can install them into their profile themselves.

As for the tests, my impression is that they are actually not activated.
So I added a comment.

The patch is pushed now, thanks again for your patience!

Andreas
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 32d826d3c5..7e6704f4aa 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -132,6 +132,7 @@ 
 ;;; Copyright © 2022 Garek Dyszel <garekdyszel@disroot.org>
 ;;; Copyright © 2022 Baptiste Strazzulla <bstrazzull@hotmail.fr>
 ;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
+;;; Copyright © 2023 Gabriel Wicki <gabriel@erlikon.ch>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1462,6 +1463,27 @@  (define-public python-psutil
 iotop, uptime, pidof, tty, taskset, pmap.")
     (license license:bsd-3)))
 
+(define-public python-scapy
+  (package
+    (name "python-scapy")
+    (version "2.5.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "scapy" version))
+              (sha256
+               (base32
+                "1hpbbmpcn4dwj3z7i7sz4cnbpkaf57p7mvl3p84x9n2gflmhq9jv"))))
+    (arguments
+     '(#:tests? #f)) ;no test
+    (build-system python-build-system)
+    (home-page "https://scapy.net")
+    (synopsis "Python network packet crafting library")
+    (description
+     "Scapy is a powerful interactive packet manipulation program.
+It is able to forge or decode packets of a wide number of protocols, send them
+on the wire, capture them, match requests and replies, and much more.")
+    (license license:gpl2)))
+
 (define-public python-shapely
   (package
     (name "python-shapely")