diff mbox series

[bug#59093,v2,1/2] gnu: Add motif

Message ID 20230111145604.2643141-1-zimon.toutoune@gmail.com
State New
Headers show
Series [bug#59093,v2,1/2] gnu: Add motif | expand

Commit Message

Simon Tournier Jan. 11, 2023, 2:56 p.m. UTC
From: Andy Tai <atai@atai.org>

* gnu/packages/lesstif.scm (motif): New variable
---
 gnu/packages/lesstif.scm | 40 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)


base-commit: a8b2decf287498eeb51ef23712c5bd01b60cb18b
diff mbox series

Patch

diff --git a/gnu/packages/lesstif.scm b/gnu/packages/lesstif.scm
index 8f017f41be..1ab471e4fa 100644
--- a/gnu/packages/lesstif.scm
+++ b/gnu/packages/lesstif.scm
@@ -1,5 +1,6 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2022 Andy Tai <atai@atai.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -21,6 +22,12 @@  (define-module (gnu packages lesstif)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
+  #:use-module (guix git-download)
+  #:use-module (gnu packages autotools)
+  #:use-module (gnu packages c)
+  #:use-module (gnu packages flex)
+  #:use-module (gnu packages fontutils)
+  #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages xorg))
 
 
@@ -46,3 +53,36 @@  (define-public lesstif
     (synopsis "Clone of the Motif toolkit for the X window system")
     (description "Clone of the Motif toolkit for the X window system.")
     (license license:gpl2+))) ; some files are lgpl2.1+ or x11
+
+(define-public motif
+  ;; This commit is from September 2021 and v2.3.8 from 2017.
+  (let ((commit "59858b0811e8d9dfaeb142f2b5a96f55482be1ed")
+        (revision "0"))
+    (package
+      (name "motif")
+      (version (git-version "2.3.8" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://git.code.sf.net/p/motif/code")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "0yycq0vzga9qmgbfzn2d02ilpwxixwdv2j1d8sddl4dripcrg21m"))))
+      (build-system gnu-build-system)
+      (inputs
+       (list libx11 xorgproto))
+      (propagated-inputs
+       (list fontconfig freetype libxext libxft libxpm libxt xbitmaps))
+      (native-inputs
+       (list autoconf automake byacc flex libtool pkg-config))
+      (home-page "https://motif.ics.com/motif")
+      (synopsis "Motif toolkit for the X window system")
+      (description "Motif is a standard graphical user interface, (as
+defined by the IEEE 1295 specification), used on more than 200 hardware and
+software platforms.  It provides application developers, end users, and system
+vendors with a widely used environment for standardizing
+application presentation on a wide range of platforms.")
+      (license license:lgpl2.1+))))