diff mbox series

[bug#60729] gnu: Add cellsnp-lite.

Message ID 20230111134744.2551087-1-zimon.toutoune@gmail.com
State New
Headers show
Series [bug#60729] gnu: Add cellsnp-lite. | expand

Commit Message

Simon Tournier Jan. 11, 2023, 1:47 p.m. UTC
From: Simon Tournier <zimon.toutoune@gmail.com>

* gnu/packages/bioinformatics.scm (cellsnp-lite): New variable.
---
 gnu/packages/bioinformatics.scm | 44 ++++++++++++++++++++++++++++++++-
 1 file changed, 43 insertions(+), 1 deletion(-)


base-commit: a8b2decf287498eeb51ef23712c5bd01b60cb18b

Comments

Ricardo Wurmus Jan. 12, 2023, 8:38 p.m. UTC | #1
zimoun <zimon.toutoune@gmail.com> writes:

> From: Simon Tournier <zimon.toutoune@gmail.com>
>
> * gnu/packages/bioinformatics.scm (cellsnp-lite): New variable.

Applied, thank you!
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 6e909773a7..4ef9ec15b0 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -21,7 +21,7 @@ 
 ;;; Copyright © 2020 Bonface Munyoki Kilyungi <bonfacemunyoki@gmail.com>
 ;;; Copyright © 2021 Tim Howes <timhowes@lavabit.com>
 ;;; Copyright © 2021 Hong Li <hli@mdc-berlin.de>
-;;; Copyright © 2021, 2022 Simon Tournier <zimon.toutoune@gmail.com>
+;;; Copyright © 2021, 2022, 2023 Simon Tournier <zimon.toutoune@gmail.com>
 ;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
 ;;; Copyright © 2022 Navid Afkhami <navid.afkhami@mdc-berlin.de>
 ;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
@@ -512,6 +512,48 @@  (define-public bedtools-2.18
     (inputs
      (list samtools zlib))))
 
+(define-public cellsnp-lite
+  ;; Last release from November 2021 and does not contain fixes.
+  (let ((commit "0885d746b0b1ea65c8ef92f8943ca7669ca9734a")
+        (revision "0"))
+    (package
+      (name "cellsnp-lite")
+      (version (git-version "1.2.2" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/single-cell-genetics/cellsnp-lite")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1qrvqgbvw6mbhpyqvqbmvv8dmyc67bsk1041cn7ib6zmd47qm444"))))
+      (build-system gnu-build-system)
+      (arguments
+       (list
+        #:configure-flags #~(list (string-append "--with-htslib="
+                                                 #$(this-package-input "htslib")))))
+      (inputs
+       (list curl
+             htslib
+             openssl
+             zlib))
+      (native-inputs
+       (list autoconf))
+      (home-page "https://cellsnp-lite.readthedocs.io")
+      (synopsis "Pileup expresses alleles in single-cell or bulk RNA-seq data")
+      (description
+       "This package is designed to pileup the expressed alleles in
+single-cell or bulk RNA-seq data, which can be directly used for donor
+deconvolution in multiplexed single-cell RNA-seq data, particularly with other
+packages, which assigns cells to donors and detects doublets as vireo, even
+without genotyping reference.
+
+This package is the C version of the deprecated cellSNP implemented in Python.
+Comparedto cellSNP, this package is more efficient with higher speed and less
+memory usage.")
+      (license license:asl2.0))))
+
 (define-public pbcopper
   (package
     (name "pbcopper")