diff mbox series

[bug#60706] gnu: hwloc: Update to 2.9.0.

Message ID 20230110090414.32124-1-ludo@gnu.org
State New
Headers show
Series [bug#60706] gnu: hwloc: Update to 2.9.0. | expand

Commit Message

Ludovic Courtès Jan. 10, 2023, 9:04 a.m. UTC
From: Ludovic Courtès <ludovic.courtes@inria.fr>

* gnu/packages/mpi.scm (hwloc-2): Update to 2.9.0.
[arguments]: Add 'skip-test-that-requires-/sys' phase.
---
 gnu/packages/mpi.scm | 10 +++++++---
 1 file changed, 7 insertions(+), 3 deletions(-)


base-commit: 84f117f49587b608b287827793b1b8036d2cff7f

Comments

Maxim Cournoyer Jan. 10, 2023, 4:34 p.m. UTC | #1
Hi,

Ludovic Courtès <ludo@gnu.org> writes:

> From: Ludovic Courtès <ludovic.courtes@inria.fr>
>
> * gnu/packages/mpi.scm (hwloc-2): Update to 2.9.0.
> [arguments]: Add 'skip-test-that-requires-/sys' phase.
> ---
>  gnu/packages/mpi.scm | 10 +++++++---
>  1 file changed, 7 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
> index af2409aeab..56b7d04209 100644
> --- a/gnu/packages/mpi.scm
> +++ b/gnu/packages/mpi.scm
> @@ -1,6 +1,6 @@
>  ;;; GNU Guix --- Functional package management for GNU
>  ;;; Copyright © 2014, 2015, 2018, 2019 Eric Bavier <bavier@member.fsf.org>
> -;;; Copyright © 2014-2022 Ludovic Courtès <ludo@gnu.org>
> +;;; Copyright © 2014-2023 Ludovic Courtès <ludo@gnu.org>
>  ;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
>  ;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
>  ;;; Copyright © 2017 Dave Love <fx@gnu.org>

Nitpick: arguably not a copyrightable change (< 10 lines of additions).

> @@ -143,7 +143,7 @@ (define-public hwloc-2
>    ;; Note: 2.x isn't the default yet, see above.
>    (package
>      (inherit hwloc-1)
> -    (version "2.8.0")
> +    (version "2.9.0")
>      (source (origin
>                (method url-fetch)
>                (uri (string-append "https://download.open-mpi.org/release/hwloc/v"
> @@ -151,7 +151,7 @@ (define-public hwloc-2
>                                    "/hwloc-" version ".tar.bz2"))
>                (sha256
>                 (base32
> -                "1ha23yqfx9kfxm5fcj9m0fnyf0r2k6p4k88xxqishclcsky752il"))))
> +                "11v8hnl6fdsdbm3wnz5gg88f2ghixjyl7jlfmywj293ab5iyjw10"))))
>  
>      ;; libnuma is no longer needed.
>      (inputs (modify-inputs (package-inputs hwloc-1)
> @@ -167,6 +167,10 @@ (define-public hwloc-2
>                 (substitute* "tests/hwloc/linux-libnuma.c"
>                   (("numa_available\\(\\)")
>                    "-1"))))
> +           (add-before 'check 'skip-test-that-requires-/sys
> +             (lambda _
> +               ;; 'test-gather-topology.sh' requires /sys as of 2.9.0; skip it.
> +               (setenv "HWLOC_TEST_GATHER_TOPOLOGY" "0")))
>             (add-before 'check 'skip-test-that-fails-on-qemu
>               (lambda _
>                 ;; Skip test that fails on emulated hardware due to QEMU bug:

Otherwise LGTM.
Ludovic Courtès Jan. 10, 2023, 5:06 p.m. UTC | #2
Maxim Cournoyer <maxim.cournoyer@gmail.com> skribis:

> Ludovic Courtès <ludo@gnu.org> writes:
>
>> From: Ludovic Courtès <ludovic.courtes@inria.fr>
>>
>> * gnu/packages/mpi.scm (hwloc-2): Update to 2.9.0.
>> [arguments]: Add 'skip-test-that-requires-/sys' phase.
>> ---
>>  gnu/packages/mpi.scm | 10 +++++++---
>>  1 file changed, 7 insertions(+), 3 deletions(-)
>>
>> diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
>> index af2409aeab..56b7d04209 100644
>> --- a/gnu/packages/mpi.scm
>> +++ b/gnu/packages/mpi.scm
>> @@ -1,6 +1,6 @@
>>  ;;; GNU Guix --- Functional package management for GNU
>>  ;;; Copyright © 2014, 2015, 2018, 2019 Eric Bavier <bavier@member.fsf.org>
>> -;;; Copyright © 2014-2022 Ludovic Courtès <ludo@gnu.org>
>> +;;; Copyright © 2014-2023 Ludovic Courtès <ludo@gnu.org>
>>  ;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
>>  ;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
>>  ;;; Copyright © 2017 Dave Love <fx@gnu.org>
>
> Nitpick: arguably not a copyrightable change (< 10 lines of additions).

Riiight.

> Otherwise LGTM.

Thanks for taking a look!

Let’s see if <https://qa.guix.gnu.org/issue/60706> can tell us more
about dependents and non-x86 architectures…

Ludo’.
Ludovic Courtès Jan. 27, 2023, 5:19 p.m. UTC | #3
Ludovic Courtès <ludovic.courtes@inria.fr> skribis:

> Let’s see if <https://qa.guix.gnu.org/issue/60706> can tell us more
> about dependents and non-x86 architectures…

Pushed as 317ea0458927810754ab154228ace04ff7bab717 with a fix for the
issues qa.guix found in dependent packages.

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index af2409aeab..56b7d04209 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -1,6 +1,6 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014, 2015, 2018, 2019 Eric Bavier <bavier@member.fsf.org>
-;;; Copyright © 2014-2022 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014-2023 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
 ;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2017 Dave Love <fx@gnu.org>
@@ -143,7 +143,7 @@  (define-public hwloc-2
   ;; Note: 2.x isn't the default yet, see above.
   (package
     (inherit hwloc-1)
-    (version "2.8.0")
+    (version "2.9.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://download.open-mpi.org/release/hwloc/v"
@@ -151,7 +151,7 @@  (define-public hwloc-2
                                   "/hwloc-" version ".tar.bz2"))
               (sha256
                (base32
-                "1ha23yqfx9kfxm5fcj9m0fnyf0r2k6p4k88xxqishclcsky752il"))))
+                "11v8hnl6fdsdbm3wnz5gg88f2ghixjyl7jlfmywj293ab5iyjw10"))))
 
     ;; libnuma is no longer needed.
     (inputs (modify-inputs (package-inputs hwloc-1)
@@ -167,6 +167,10 @@  (define-public hwloc-2
                (substitute* "tests/hwloc/linux-libnuma.c"
                  (("numa_available\\(\\)")
                   "-1"))))
+           (add-before 'check 'skip-test-that-requires-/sys
+             (lambda _
+               ;; 'test-gather-topology.sh' requires /sys as of 2.9.0; skip it.
+               (setenv "HWLOC_TEST_GATHER_TOPOLOGY" "0")))
            (add-before 'check 'skip-test-that-fails-on-qemu
              (lambda _
                ;; Skip test that fails on emulated hardware due to QEMU bug: