diff mbox series

[bug#60571,1/4] gnu: Add spirv-headers-for-skia.

Message ID 20230105121842.18662-1-ngraves@ngraves.fr
State New
Headers show
Series [bug#60571,1/4] gnu: Add spirv-headers-for-skia. | expand

Commit Message

Nicolas Graves Jan. 5, 2023, 12:18 p.m. UTC
* gnu/packages/vulkan.scm (spirv-headers-for-skia): New variable.
---
 gnu/packages/vulkan.scm | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)

Comments

Maxim Cournoyer March 24, 2023, 3:15 a.m. UTC | #1
Hello,

Nicolas Graves <ngraves@ngraves.fr> writes:

> * gnu/packages/vulkan.scm (spirv-headers-for-skia): New variable.
> ---
>  gnu/packages/vulkan.scm | 17 +++++++++++++++++
>  1 file changed, 17 insertions(+)
>
> diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
> index a2db5511d5..8895d8a5cf 100644
> --- a/gnu/packages/vulkan.scm
> +++ b/gnu/packages/vulkan.scm
> @@ -74,6 +74,23 @@ (define-public spirv-headers
>                (string-append "https://github.com/KhronosGroup/SPIRV-Headers/blob/"
>                               version "/LICENSE")))))
>  
> +(define-public spirv-headers-for-skia

Could you please add a comment here about why we use this commit, and
not a release, e.g. ("There is no release; use the latest commit.")

> +  (let ((commit "814e728b30ddd0f4509233099a3ad96fd4318c07")
> +        (revision "0"))
> +    (package
> +      (inherit spirv-headers)
> +      (name "spirv-headers-for-skia")
> +      (version "skia")

That's not OK as a version.  See if there is a version string in the
source, and use that else 0.0.0, combined wih revision and commit via
the 'git-version' procedure.

Thanks for working on it!
diff mbox series

Patch

diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index a2db5511d5..8895d8a5cf 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -74,6 +74,23 @@  (define-public spirv-headers
               (string-append "https://github.com/KhronosGroup/SPIRV-Headers/blob/"
                              version "/LICENSE")))))
 
+(define-public spirv-headers-for-skia
+  (let ((commit "814e728b30ddd0f4509233099a3ad96fd4318c07")
+        (revision "0"))
+    (package
+      (inherit spirv-headers)
+      (name "spirv-headers-for-skia")
+      (version "skia")
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://skia.googlesource.com/external/github.com/KhronosGroup/SPIRV-Headers.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0v6ycgfxh9d2gzhxrnxgrn5gyg2cshg55767qdg46px8412j5lbi")))))))
+
 (define-public spirv-tools
   (package
     (name "spirv-tools")