diff mbox series

[bug#60517] gnu: neovim: Update to 0.8.2.

Message ID 20230103142511.6972-1-luishenriquegh2701@gmail.com
State New
Headers show
Series [bug#60517] gnu: neovim: Update to 0.8.2. | expand

Commit Message

Luis Henrique Gomes Higino Jan. 3, 2023, 2:25 p.m. UTC
* gnu/packages/vim.scm (neovim): Update to 0.8.2.
---
Hi Guix,

this patch updates neovim to the latest release. However, while checking the package build I noticed that it has not been reproducible since fbdd0a4a14b968997a511bbf2634640529345904. I have not been able to find what is the root cause, since luajit (the package updated in that commit) remained reproducible.

Thanks,
Luis Higino

 gnu/packages/vim.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)


base-commit: 473692b812b4ab4267d9bddad0fb27787d2112ff

Comments

Ludovic Courtès Jan. 10, 2023, 9:56 a.m. UTC | #1
Hi,

Luis Henrique Gomes Higino <luishenriquegh2701@gmail.com> skribis:

> * gnu/packages/vim.scm (neovim): Update to 0.8.2.

Applied, thanks!

> this patch updates neovim to the latest release. However, while checking the package build I noticed that it has not been reproducible since fbdd0a4a14b968997a511bbf2634640529345904. I have not been able to find what is the root cause, since luajit (the package updated in that commit) remained reproducible.

Would you like to email your findings so far to bug-guix@gnu.org?  That
way we’ll keep track of it and hopefully someone else can give a hand.

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 1451bf80a3..6939057ff2 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -12,7 +12,7 @@ 
 ;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
 ;;; Copyright © 2021 Tissevert <tissevert+guix@marvid.fr>
 ;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
-;;; Copyright © 2022 Luis Henrique Gomes Higino <luishenriquegh2701@gmail.com>
+;;; Copyright © 2022, 2023 Luis Henrique Gomes Higino <luishenriquegh2701@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -692,7 +692,7 @@  (define-public neovim-syntastic
 (define-public neovim
   (package
     (name "neovim")
-    (version "0.8.1")
+    (version "0.8.2")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -701,7 +701,7 @@  (define-public neovim
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "08qyni2qg63ghxl50am97pajdhkp05s1cglis3mlvkxx3pvzkrli"))))
+                "1jjw9a42l7wrziki2qznn7wiw5r59n4hs9i6g2hxnjyzixpg9xvl"))))
     (build-system cmake-build-system)
     (arguments
      (list #:modules