diff mbox series

[bug#60495] gnu: Add python-docx.

Message ID 20230102153255.4791-1-maxim.cournoyer@gmail.com
State New
Headers show
Series [bug#60495] gnu: Add python-docx. | expand

Commit Message

Maxim Cournoyer Jan. 2, 2023, 3:32 p.m. UTC
* gnu/packages/python-xyz.scm (python-docx): New variable.
---

 gnu/packages/python-xyz.scm | 27 ++++++++++++++++++++++++++-
 1 file changed, 26 insertions(+), 1 deletion(-)


base-commit: 7efcf36e3b753a1dba6f8208f3c22d151007eaf0

Comments

jgart Jan. 2, 2023, 4:36 p.m. UTC | #1
Hi Maxim and Lars-Dominik,

I tested building python-docx locally and it builds fine. 

I also ran `guix lint -n` and `guix refresh -l` on it. 

Thanks!

all best,

jgart
Maxim Cournoyer Jan. 2, 2023, 8:05 p.m. UTC | #2
Hi jgart,

"jgart" <jgart@dismail.de> writes:

> Hi Maxim and Lars-Dominik,
>
> I tested building python-docx locally and it builds fine. 
>
> I also ran `guix lint -n` and `guix refresh -l` on it. 

Applied, thanks for the prompt review!
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3bdd1e00d6..9526447a2a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -52,7 +52,7 @@ 
 ;;; Copyright © 2018-2022 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
 ;;; Copyright © 2018, 2019, 2021 Clément Lassieur <clement@lassieur.org>
-;;; Copyright © 2018, 2019, 2020, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2018, 2019, 2020, 2021, 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2018 Luther Thompson <lutheroto@gmail.com>
 ;;; Copyright © 2018 Vagrant Cascadian <vagrant@debian.org>
 ;;; Copyright © 2015, 2018 Pjotr Prins <pjotr.guix@thebird.nl>
@@ -4885,6 +4885,31 @@  (define-public python-docutils-0.15
     ;; tests contain Python 2 syntax.
     (arguments '(#:tests? #false))))
 
+(define-public python-docx
+  (package
+    (name "python-docx")
+    (version "0.8.11")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "python-docx" version))
+              (sha256
+               (base32
+                "1i7bxghb7knlyjain101qg1jmmz2b6qj03bi3vfxhvcml0rx418i"))))
+    (build-system pyproject-build-system)
+    (native-inputs
+     (list behave
+           python-flake8
+           python-mock
+           python-pyparsing
+           python-pytest))
+    (propagated-inputs
+     (list python-lxml))
+    (home-page "https://github.com/python-openxml/python-docx/")
+    (synopsis "Python library to create and modify Microsoft Word documents")
+    (description "This Python library can be used to create and update
+Microsoft Word (.docx) documents.")
+    (license license:expat)))
+
 (define-public python-restructuredtext-lint
   (package
     (name "python-restructuredtext-lint")