diff mbox series

[bug#60350] gnu: Add emacs-consult-xdg-recent-files.

Message ID 20221227071313.9108-1-ngraves@ngraves.fr
State New
Headers show
Series [bug#60350] gnu: Add emacs-consult-xdg-recent-files. | expand

Commit Message

Nicolas Graves Dec. 27, 2022, 7:13 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-consult-xdg-recent-files): New variable.
---
 gnu/packages/emacs-xyz.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

Comments

Nicolas Goaziou Dec. 28, 2022, 9:41 a.m. UTC | #1
Hello,

Nicolas Graves via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-consult-xdg-recent-files): New
> variable.

Applied. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8fec7b058f..6906be8b6c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -10345,6 +10345,37 @@  (define-public emacs-eglot-tempel
 library with Eglot instead of Yasnippet.")
       (license license:gpl3+))))
 
+(define-public emacs-consult-xdg-recent-files
+  (let ((commit "593023ffb99a368152ebd4e739488fa560bdfdea")
+        (revision "0"))
+    (package
+      (name "emacs-consult-xdg-recent-files")
+      (version (git-version "0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/hrehfeld/consult-xdg-recent-files")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0nd23n67dmlflw52dc1rbhy04mc9ymydnsmvfr75hqb7sznn3343"))))
+      (build-system emacs-build-system)
+      (propagated-inputs (list emacs-consult))
+      (home-page "https://github.com/hrehfeld/consult-xdg-recent-files")
+      (synopsis "Include files used by other programs than emacs in consult")
+      (description
+       "This packages provides the ability to include files used by other
+programs in the candidate lists of commands like @code{consult-recent-file}
+and @code{consult-buffer}.  This allows to use the same interface for file
+opening.
+
+In Linux (or, more specifically, on systems that comply with the XDG
+specification), these files are listed in the file @code{recently-used.xbel},
+which is found in the directory @code{~/.local/share} or the location
+described by the environment variable @code{XDG_DATA_HOME}.")
+      (license license:gpl3+))))
+
 (define-public emacs-consult-yasnippet
   (let ((commit "ae0450889484f23dc4ec37518852a2c61b89f184")
         (revision "0"))