diff mbox series

[bug#60345] gnu: perl-image-exiftool: Update to 12.50, use new package style.

Message ID 20221226210133.16139-1-kiasoc5@disroot.org
State New
Headers show
Series [bug#60345] gnu: perl-image-exiftool: Update to 12.50, use new package style. | expand

Commit Message

kiasoc5 Dec. 26, 2022, 9:01 p.m. UTC
* gnu/packages/photo.scm (perl-image-exiftool): Update to 12.50.
[arguments]: Use G-expresisons. Remove trailing #t. Use #$output instead of assoc-ref.
---
 gnu/packages/photo.scm | 27 ++++++++++++---------------
 1 file changed, 12 insertions(+), 15 deletions(-)


base-commit: 7c476873e0300711bf92668cf01abd28f7295ead

Comments

Christopher Baines Jan. 16, 2023, 8:39 p.m. UTC | #1
kiasoc5 via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/photo.scm (perl-image-exiftool): Update to 12.50.
> [arguments]: Use G-expresisons. Remove trailing #t. Use #$output instead of assoc-ref.
> ---
>  gnu/packages/photo.scm | 27 ++++++++++++---------------
>  1 file changed, 12 insertions(+), 15 deletions(-)

Looks good to me, pushed to master as
ab09e8e578480463bafd8e21451acf9dd6ddd74f.

Thanks,

Chris
diff mbox series

Patch

diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index 4d85611101..2a8a8de25d 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -299,7 +299,7 @@  (define-public gphoto2
 (define-public perl-image-exiftool
   (package
     (name "perl-image-exiftool")
-    (version "12.16")
+    (version "12.50")
     (source
      (origin
        (method url-fetch)
@@ -309,24 +309,21 @@  (define-public perl-image-exiftool
              ;; New releases may take a while to hit CPAN.
              (string-append "https://www.sno.phy.queensu.ca/~phil/exiftool/"
                             "Image-ExifTool-" version ".tar.gz")))
-       (patches (search-patches "perl-image-exiftool-CVE-2021-22204.patch"))
        (sha256
         (base32
-         "0skm22b3gg1bfk0amklrprpva41m6mkrhqp0gi7z1nmcf9ypjh61"))))
+         "1a605rz00d7p866a22sw0s63m5a6y4xqqrzp7q7jyc0hbky43s5w"))))
     (build-system perl-build-system)
     (arguments
-     '(#:phases
-       (modify-phases %standard-phases
-         (add-after 'install 'post-install
-           (lambda* (#:key outputs #:allow-other-keys)
-             ;; Make sure the 'exiftool' commands finds the library.
-             ;; XXX: Shouldn't it be handled by PERL-BUILD-SYSTEM?
-             (let* ((out (assoc-ref outputs "out"))
-                    (pm  (find-files out "^ExifTool\\.pm$"))
-                    (lib (dirname (dirname (car pm)))))
-               (wrap-program (string-append out "/bin/exiftool")
-                 `("PERL5LIB" prefix (,lib)))
-               #t))))))
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'install 'post-install
+                 (lambda* (#:key outputs #:allow-other-keys)
+                   ;; Make sure the 'exiftool' commands finds the library.
+                   ;; XXX: Shouldn't it be handled by PERL-BUILD-SYSTEM?
+                   (let* ((pm  (find-files #$output "^ExifTool\\.pm$"))
+                          (lib (dirname (dirname (car pm)))))
+                     (wrap-program (string-append #$output "/bin/exiftool")
+                       `("PERL5LIB" prefix (,lib)))))))))
     (home-page "https://metacpan.org/release/Image-ExifTool")
     (synopsis "Program and Perl library to manipulate EXIF and other metadata")
     (description "This package provides the @code{exiftool} command and the