diff mbox series

[bug#60343] gnu: latex2html: Update to 2022.2, use new package style.

Message ID 20221226205516.14502-1-kiasoc5@disroot.org
State New
Headers show
Series [bug#60343] gnu: latex2html: Update to 2022.2, use new package style. | expand

Commit Message

kiasoc5 Dec. 26, 2022, 8:55 p.m. UTC
* gnu/packages/documentation.scm (latex2html): Update to 2022.2.
[arguments]: Use G-expressions. Remove trailing #t. Use #$output instead of
assoc-ref.
---
 gnu/packages/documentation.scm | 41 ++++++++++++++++------------------
 1 file changed, 19 insertions(+), 22 deletions(-)


base-commit: 7c476873e0300711bf92668cf01abd28f7295ead

Comments

Christopher Baines Jan. 16, 2023, 8:38 p.m. UTC | #1
kiasoc5 via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/documentation.scm (latex2html): Update to 2022.2.
> [arguments]: Use G-expressions. Remove trailing #t. Use #$output instead of
> assoc-ref.
> ---
>  gnu/packages/documentation.scm | 41 ++++++++++++++++------------------
>  1 file changed, 19 insertions(+), 22 deletions(-)

Looks good to me :) Pushed to master as
ab09e8e578480463bafd8e21451acf9dd6ddd74f.

Thanks,

Chris
diff mbox series

Patch

diff --git a/gnu/packages/documentation.scm b/gnu/packages/documentation.scm
index 3ded8e1cac..f0cc10bc49 100644
--- a/gnu/packages/documentation.scm
+++ b/gnu/packages/documentation.scm
@@ -66,7 +66,7 @@  (define-module (gnu packages documentation)
 (define-public latex2html
   (package
     (name "latex2html")
-    (version "2020.2")
+    (version "2022.2")
     (source
      (origin
        (method git-fetch)
@@ -76,29 +76,26 @@  (define-public latex2html
          (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1icyl6kl60wh7cavprgbd8q6lpjwr7wn24m34kpiif7ahknhcbcm"))))
+        (base32 "1z71anjzxy5jsdlaqba4w9spncc6iycldarnr2z1dq8xmk6yhpjn"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'patch-configure
-           (lambda* (#:key outputs #:allow-other-keys)
-             (substitute* "configure"
-               (("/usr/local")
-                (assoc-ref outputs "out"))
-               (("\\$\\{CONFIG_SHELL-/bin/sh\\}")
-                (which "bash")))
-             #t))
-         (replace 'configure
-           (lambda _
-             (invoke "./configure")
-             #t))
-         (add-after 'configure 'patch-cfgcache
-           (lambda* (#:key outputs #:allow-other-keys)
-             (substitute* "cfgcache.pm"
-               (("/usr/local")
-                (assoc-ref outputs "out")))
-             #t)))))
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'unpack 'patch-configure
+                 (lambda* (#:key outputs #:allow-other-keys)
+                   (substitute* "configure"
+                     (("/usr/local")
+                      #$output)
+                     (("\\$\\{CONFIG_SHELL-/bin/sh\\}")
+                      (which "bash")))))
+               (replace 'configure
+                 (lambda _
+                   (invoke "./configure")))
+               (add-after 'configure 'patch-cfgcache
+                 (lambda* (#:key outputs #:allow-other-keys)
+                   (substitute* "cfgcache.pm"
+                     (("/usr/local")
+                      #$output)))))))
     (inputs
      (list perl))
     (synopsis "LaTeX documents to HTML")