diff mbox series

[bug#60330,Draft] gnu: lilypond: Update to 2.24.0

Message ID 20221226032737.31606-1-jgart@dismail.de
State New
Headers show
Series [bug#60330,Draft] gnu: lilypond: Update to 2.24.0 | expand

Commit Message

jgart Dec. 26, 2022, 3:27 a.m. UTC
* gnu/packages/music.scm (lilypond): Update to 2.24.0
[arguments]: Remove adjust-to-API-change, prepare-configuration, and
install-info phases. Use disable-documentation flag and GUILE_FLAVOUR
environment variable. Remove make-flags keyword option.
[inputs]: Add extractpdfmark and update guile to 3.0.
[native-inputs]: Update Python 2 to 3 and add missing texlive-fontinst
and texlive-lm

hi, this is a wip. Any code review much appreciated!
---
 gnu/packages/music.scm | 68 ++++++++++++++----------------------------
 1 file changed, 22 insertions(+), 46 deletions(-)

Comments

Jonathan Brielmaier Feb. 6, 2023, 10:30 p.m. UTC | #1
Hi Jorge,

I was suprised that we didn't had the most recent version of lilypond
already in Guix :) So, thanks for your patch.

I pushed it as 1df2430f4625b46e8493c94d24982bbe3f78b959 with an update
to the home-page link (guix lint told that).

Additionaly I removed the input labels in a follow up commit.

~Jonathan
diff mbox series

Patch

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 5be767a138..63e9732613 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -49,6 +49,7 @@ 
 ;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2022 Wamm K. D. <jaft.r@outlook.com>
 ;;; Copyright © 2022 Jose G Perez Taveras <josegpt27@gmail.com>
+;;; Copyright © 2022 jgart <jgart@dismail.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -96,6 +97,7 @@  (define-module (gnu packages music)
   #:use-module (gnu packages backup)
   #:use-module (gnu packages base) ;libbdf
   #:use-module (gnu packages bash)
+  #:use-module (gnu packages bdw-gc)
   #:use-module (gnu packages benchmark)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages boost)
@@ -1385,7 +1387,7 @@  (define-public ninjas2
 (define-public lilypond
   (package
     (name "lilypond")
-    (version "2.20.0")
+    (version "2.24.0")
     (source
      (origin
        (method url-fetch)
@@ -1393,60 +1395,32 @@  (define-public lilypond
                            "v" (version-major+minor version) "/"
                            "lilypond-" version ".tar.gz"))
        (sha256
-        (base32 "0qd6pd4siss016ffmcyw5qc6pr2wihnvrgd4kh1x725w7wr02nar"))))
+        (base32 "0scbyzbxqnzgibls62npg2i3sywnb146gw7jlvinj9dhj8xvxv9w"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:tests? #f                      ;out-test/collated-files.html fails
-       #:out-of-source? #t
-       #:make-flags '("conf=www")       ;to generate images for info manuals
-       #:configure-flags
-       (list "CONFIGURATION=www"
-             (string-append "--with-texgyre-dir="
-                            (assoc-ref %build-inputs "font-tex-gyre")
-                            "/share/fonts/opentype/"))
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'fix-path-references
-           (lambda _
-             (substitute* "scm/backend-library.scm"
-               (("\\(search-executable '\\(\"gs\"\\)\\)")
-                (string-append "\"" (which "gs") "\""))
-               (("\"/bin/sh\"")
-                (string-append "\"" (which "sh") "\"")))))
-         (add-after 'fix-path-references 'adjust-to-API-change
-           (lambda _
-             (substitute* '("Documentation/pictures/GNUmakefile"
-                            "stepmake/stepmake/tex-rules.make")
-               ((".*-c .setpdfwrite.*") ""))
-             (substitute* "scm/backend-library.scm"
-               (("\"-c.setpdfwrite\"") ""))
-             (substitute* "scm/framework-ps.scm"
-               (("\".setpdfwrite ") "\""))))
-         (add-before 'configure 'prepare-configuration
-           (lambda _
-             (substitute* "configure"
-               (("SHELL=/bin/sh") "SHELL=sh")
-               ;; When checking the fontforge version do not consider the
-               ;; version string that's part of the directory.
-               (("head -n") "tail -n")
-               ;; Also allow for SOURCE_DATE_EPOCH = 0 in fontforge.
-               (("20110222") "19700101"))
-             (setenv "out" "www")
-             (setenv "conf" "www")))
-         (add-after 'install 'install-info
-           (lambda _
-             (invoke "make"
-                     "-j" (number->string (parallel-job-count))
-                     "conf=www" "install-info"))))))
+      (list #:tests? #f                      ;out-test/collated-files.html fails
+            #:out-of-source? #t
+            #:configure-flags
+            #~(list "--disable-documentation" "GUILE_FLAVOR=guile-3.0")
+            #:phases
+            #~(modify-phases %standard-phases
+                (add-after 'unpack 'fix-path-references
+                  (lambda* (#:key inputs #:allow-other-keys)
+                    (substitute* "scm/backend-library.scm"
+                      (("\\(search-executable '\\(\"gs\"\\)\\)")
+                       (string-append "\"" (search-input-file inputs "bin/gs") "\""))
+                      (("\"/bin/sh\"")
+                       (string-append "\"" (search-input-file inputs "bin/sh") "\""))))))))
     (inputs
-     `(("guile" ,guile-1.8)
+     `(("guile" ,guile-3.0)
+       ("extractpdfmark" ,extractpdfmark)
        ("font-dejavu" ,font-dejavu)
        ("font-tex-gyre" ,font-tex-gyre)
        ("fontconfig" ,fontconfig)
        ("freetype" ,freetype)
        ("ghostscript" ,ghostscript)
        ("pango" ,pango)
-       ("python" ,python-2)))
+       ("python" ,python)))
     (native-inputs
      `(("bison" ,bison)
        ("perl" ,perl)
@@ -1458,7 +1432,9 @@  (define-public lilypond
        ("netpbm" ,netpbm)               ;for pngtopnm
        ("texlive" ,(texlive-updmap.cfg (list texlive-metapost
                                         texlive-epsf
+                                        texlive-fontinst
                                         texlive-lh
+                                        texlive-lm
                                         texlive-latex-cyrillic)))
        ("texinfo" ,texinfo)
        ("texi2html" ,texi2html-1.82)