diff mbox series

[bug#60324,3/3] gnu: Add python-scikit-rf.

Message ID 20221225225801.829867-3-monego@posteo.net
State New
Headers show
Series Add python-scikit-rf. | expand

Commit Message

Vinicius Monego Dec. 25, 2022, 10:58 p.m. UTC
* gnu/packages/engineering.scm (python-scikit-rf): New variable.
---
 gnu/packages/engineering.scm | 37 ++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 26f0db03d7..03b2ff2ffc 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2412,6 +2412,43 @@  (define-public python-pyvisa
 test equipment via GPIB, RS232, Ethernet or USB.")
     (license license:expat)))
 
+(define-public python-scikit-rf
+  (package
+    (name "python-scikit-rf")
+    (version "0.24.1")
+    (source (origin
+              (method git-fetch) ;PyPI misses some files required for tests
+              (uri (git-reference
+                    (url "https://github.com/scikit-rf/scikit-rf")
+                    (commit (string-append "v" version))))
+              (sha256
+               (base32
+                "1shp8q8324dkwf448mv9zzi7krx882p122ma4fk015qz91sg4wff"))
+              (file-name (git-file-name name version))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-matplotlib
+                             python-networkx
+                             python-numpy
+                             python-openpyxl
+                             python-pandas
+                             python-pyqt
+                             python-pyqtgraph
+                             python-qtpy
+                             python-scipy))
+    (native-inputs (list python-coverage
+                         python-flake8
+                         python-nbval
+                         python-networkx
+                         python-pytest-7.1
+                         python-pytest-cov
+                         python-pyvisa))
+    (home-page "https://scikit-rf.org/")
+    (synopsis "RF and Microwave Engineering Scikit")
+    (description
+     "Scikit-rf (aka @code{skrf}) is a Python package for RF/Microwave
+engineering.")
+    (license license:bsd-3)))
+
 (define-public openscad
   (package
     (name "openscad")