diff mbox series

[bug#60282] gnu: Add python-pixelmatch.

Message ID 20221223183259.6488-1-ngraves@ngraves.fr
State New
Headers show
Series [bug#60282] gnu: Add python-pixelmatch. | expand

Commit Message

Nicolas Graves Dec. 23, 2022, 6:32 p.m. UTC
* gnu/packages/python-xyz.scm (python-pixelmatch): New variable.
---
 gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

Comments

Christopher Baines March 1, 2023, 3:26 p.m. UTC | #1
Nicolas Graves via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/python-xyz.scm (python-pixelmatch): New variable.
> ---
>  gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
>  1 file changed, 20 insertions(+)

Thanks, pushed to master as 722073b151da3f42d4e2d24fadcac561ed428a52.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5cc2061ec1..0a39dfec42 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7656,6 +7656,26 @@  (define-public python-pillow-simd
     (description "This package is a fork of Pillow which adds support for SIMD
 parallelism.")))
 
+(define-public python-pixelmatch
+  (package
+    (name "python-pixelmatch")
+    (version "0.3.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pixelmatch" version))
+       (sha256
+        (base32 "16b0cz136dcmj4dbr505igpql8dmqmr9vni5nbaa5kygjfjkdynh"))))
+    (build-system python-build-system)
+    (native-inputs (list python-pillow))
+    (home-page "https://github.com/whtsky/pixelmatch-py")
+    (synopsis "A pixel-level image comparison library")
+    (description "This package provides a pixel-level image comparison library
+for Python, originally created to compare screenshots in tests.  Its features
+include accurate anti-aliased pixels detection and perceptual color difference
+metrics.")
+    (license license:isc)))
+
 (define-public python-imagecodecs
   (package
     (name "python-imagecodecs")