diff mbox series

[bug#60239] gnu: Add python-pysimplesoap.

Message ID 20221221144821.6208-1-felix.lechner@lease-up.com
State New
Headers show
Series [bug#60239] gnu: Add python-pysimplesoap. | expand

Commit Message

Felix Lechner Dec. 21, 2022, 2:48 p.m. UTC
* gnu/packages/python-web.scm (python-pysimplesoap): New variable.
---
 gnu/packages/python-web.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 18c0b47b67..6daf82fea1 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -7964,6 +7964,26 @@  (define-public python-zeep
 @end itemize")
     (license license:expat)))
 
+(define-public python-pysimplesoap
+  (package
+    (name "python-pysimplesoap")
+    (version "1.16.2")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "PySimpleSOAP" version))
+              (sha256
+               (base32
+                "1qb7dn8m1cjwzql7vqj9i1hsscb7nyhimmlp45jrpzxds38g9fxi"))))
+    (build-system python-build-system)
+    (arguments
+     (list #:tests? #f))       ; tests fail due to attempted web access
+    (home-page "https://github.com/pysimplesoap/pysimplesoap")
+    (synopsis "Python simple and lightweight SOAP Library")
+    (description "Python simple and lightweight SOAP library for client and
+server webservices interfaces, aimed to be as small and easy as possible,
+supporting most common functionality.")
+    (license license:lgpl3+)))
+
 (define-public python-http-client
   (package
     (name "python-http-client")