diff mbox series

[bug#60238,3/7] gnu: Add python-inflect.

Message ID 20221221131404.9862-3-i@dan.games
State New
Headers show
Series gnu: Add fava. | expand

Commit Message

dan Dec. 21, 2022, 1:14 p.m. UTC
* gnu/packages/python-xyz.scm (python-inflect): New variable.
---
 gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6cdf9026b0..f0e2ad4fc4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8925,6 +8925,27 @@  (define-public python-portend
     (description "TCP port monitoring and discovery")
     (license license:expat)))
 
+(define-public python-inflect
+  (package
+    (name "python-inflect")
+    (version "6.0.2")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "inflect" version))
+              (sha256
+               (base32
+                "16ihdnwck79db21g2pnqq8acc4n68k8agqgx36bghijh22qbr9pi"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-pydantic))
+    (native-inputs (list python-pytest))
+    (home-page "https://github.com/jaraco/inflect")
+    (synopsis
+     "Correctly generate plurals, singular nouns, ordinals, indefinite articles; convert numbers to words")
+    (description
+     "Correctly generate plurals, singular nouns, ordinals, indefinite articles;
+convert numbers to words")
+    (license license:expat)))
+
 (define-public python-simplegeneric
   (package
     (name "python-simplegeneric")