diff mbox series

[bug#60212] gnu: Add emacs-fzf.

Message ID 20221220032916.5047-1-jgart@dismail.de
State New
Headers show
Series [bug#60212] gnu: Add emacs-fzf. | expand

Commit Message

jgart Dec. 20, 2022, 3:29 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-fzf): New variable.
---
 gnu/packages/emacs-xyz.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

Comments

Nicolas Goaziou Dec. 20, 2022, 10:25 a.m. UTC | #1
Hello,

jgart via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-fzf): New variable.

Thank you.

> +         #~(modify-phases %standard-phases
> +             (add-after 'unpack 'patch-fzf-executable
> +               (lambda* (#:key inputs #:allow-other-keys)
> +                 (make-file-writable "fzf.el")

Nitpick: The expression above is usually not necessary, even though some
package definitions use it.

> +                 (emacs-substitute-variables "fzf.el"
> +                   ("fzf/executable" (search-input-file inputs "/bin/fzf"))))))))
> +      (inputs (list fzf))
> +      (home-page "https://github.com/bling/fzf.el")
> +      (synopsis "Front-end for fzf")

I expounded it a bit.

> +      (description "An @command{emacs} front-end for @command{fzf}.")

Please write full sentences in descriptions, even if upstream does not.

Also, "@command{emacs}" conveys no more information than "Emacs". So
does "@command{fzf}" vs "Fzf". The simpler the better, IMO.

Applied!

Regards,
jgart Dec. 21, 2022, 12:54 a.m. UTC | #2
I keep forgetting re @command

I'll stop doing that. It has become a habit.

Thanks for the review!

It's much appreciated,

jgart

https://whereis.みんな/

December 20, 2022 4:26 AM, "Nicolas Goaziou" <mail@nicolasgoaziou.fr> wrote:

> Hello,
> 
> jgart via Guix-patches via <guix-patches@gnu.org> writes:
> 
>> * gnu/packages/emacs-xyz.scm (emacs-fzf): New variable.
> 
> Thank you.
> 
>> + #~(modify-phases %standard-phases
>> + (add-after 'unpack 'patch-fzf-executable
>> + (lambda* (#:key inputs #:allow-other-keys)
>> + (make-file-writable "fzf.el")
> 
> Nitpick: The expression above is usually not necessary, even though some
> package definitions use it.
> 
>> + (emacs-substitute-variables "fzf.el"
>> + ("fzf/executable" (search-input-file inputs "/bin/fzf"))))))))
>> + (inputs (list fzf))
>> + (home-page "https://github.com/bling/fzf.el")
>> + (synopsis "Front-end for fzf")
> 
> I expounded it a bit.
> 
>> + (description "An @command{emacs} front-end for @command{fzf}.")
> 
> Please write full sentences in descriptions, even if upstream does not.
> 
> Also, "@command{emacs}" conveys no more information than "Emacs". So
> does "@command{fzf}" vs "Fzf". The simpler the better, IMO.
> 
> Applied!
> 
> Regards,
> --
> Nicolas Goaziou
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f97775ce95..6a03d40aca 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1283,6 +1283,38 @@  (define-public emacs-mct
     (license (list license:gpl3+
                    license:fdl1.3+)))) ; GFDLv1.3+ for the manual
 
+(define-public emacs-fzf
+  (let ((commit "21912ebc7e1084aa88c9d8b7715e782a3978ed23")
+        (revision "0"))
+    (package
+      (name "emacs-fzf")
+      (version (git-version "0.0.2" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/bling/fzf.el")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0gdqjh8996hb06bnnyhi94k69mjfrzyfgq00a9s4wwagv28sqmkj"))))
+      (build-system emacs-build-system)
+      (arguments
+        (list
+         #:tests? #f ; There are no tests.
+         #:phases
+         #~(modify-phases %standard-phases
+             (add-after 'unpack 'patch-fzf-executable
+               (lambda* (#:key inputs #:allow-other-keys)
+                 (make-file-writable "fzf.el")
+                 (emacs-substitute-variables "fzf.el"
+                   ("fzf/executable" (search-input-file inputs "/bin/fzf"))))))))
+      (inputs (list fzf))
+      (home-page "https://github.com/bling/fzf.el")
+      (synopsis "Front-end for fzf")
+      (description "An @command{emacs} front-end for @command{fzf}.")
+      (license license:gpl3+))))
+
 (define-public emacs-minions
   (package
     (name "emacs-minions")