diff mbox series

[bug#60156,4/4] gnu: python-cartopy: Update to 0.21.0.

Message ID 20221217114258.5216-4-felgru@posteo.net
State New
Headers show
Series Update proj to 9.1.1. | expand

Commit Message

Felix Gruber Dec. 17, 2022, 11:42 a.m. UTC
* gnu/packages/geo.scm (python-cartopy): Update to 0.21.0.
[inputs]: Remove proj.
[native-inputs]: Add python-pytest-mpl.
---
 gnu/packages/geo.scm | 15 +++++++--------
 1 file changed, 7 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 29793ed72d..4ea960114a 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1107,13 +1107,13 @@  (define-public python-cartopy
   (package
     (name "python-cartopy")
     ;; This is a post-release fix that adds build_ext to setup.py.
-    (version "0.20.3")
+    (version "0.21.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "Cartopy" version))
        (sha256
-        (base32 "01lhnkhw22jp6hnrs5qvgkq4fqcni2sx7ydiyv8w8xxx5wpglq0d"))))
+        (base32 "0hnfs75dcnz12ximah5xn9566r8zz189lxikmj4lrs9jl4l3l7ff"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -1136,13 +1136,12 @@  (define-public python-cartopy
            python-scipy
            python-shapely))
     (inputs
-     (list geos
-           ;; cartopy's setup.py looks for the proj executable.
-           ;; Not sure if it actually makes use of it since it
-           ;; probably uses proj only through pyproj.
-           proj))
+     (list geos))
     (native-inputs
-     (list python-cython python-flufl-lock python-pytest))
+     (list python-cython
+           python-flufl-lock
+           python-pytest
+           python-pytest-mpl))
     (home-page "https://scitools.org.uk/cartopy/docs/latest/")
     (synopsis "Cartographic library for visualisation")
     (description