diff mbox series

[bug#60092] gnu: shellcheck: Update to 0.9.0.

Message ID 20221215144044.13224-1-jgart@dismail.de
State New
Headers show
Series [bug#60092] gnu: shellcheck: Update to 0.9.0. | expand

Commit Message

jgart Dec. 15, 2022, 2:40 p.m. UTC
* gnu/packages/haskell-apps.scm (shellcheck): Update to 0.9.0.
[source]: Update URL.
[inputs]: Add missing ghc-fgl input and format the list.
---
 gnu/packages/haskell-apps.scm | 13 +++++++++----
 1 file changed, 9 insertions(+), 4 deletions(-)

Comments

Simon Tournier Dec. 17, 2022, 12:26 p.m. UTC | #1
Hi,

On Thu, 15 Dec 2022 at 08:40, jgart via Guix-patches via <guix-patches@gnu.org> wrote:

> * gnu/packages/haskell-apps.scm (shellcheck): Update to 0.9.0.

Is this update compliant with the Stackage LTS version?

Cheers,
simon
宋文武 March 2, 2023, 3:48 a.m. UTC | #2
jgart <jgart@dismail.de> writes:

> * gnu/packages/haskell-apps.scm (shellcheck): Update to 0.9.0.

Hello, we have shellcheck 0.9.0 in master alreally, close now, thank
you!
diff mbox series

Patch

diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index b9e9050814..7bfdb0a8b3 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -18,6 +18,7 @@ 
 ;;; Copyright © 2021 EuAndreh <eu@euandre.org>
 ;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
 ;;; Copyright © 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
+;;; Copyright © 2022 jgart <jgart@dismail.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -826,15 +827,15 @@  (define-public scroll
 (define-public shellcheck
   (package
     (name "shellcheck")
-    (version "0.8.0")
+    (version "0.9.0")
     (source
      (origin
        (method url-fetch)
        (uri (string-append
-             "https://hackage.haskell.org/package/ShellCheck/ShellCheck-"
+             "https://github.com/koalaman/shellcheck/archive/refs/tags/v"
              version ".tar.gz"))
        (sha256
-        (base32 "05jlapp4m997w36h2wszdxz9gvczdczaylypsbn14jqpb650w232"))
+        (base32 "0j6iyygmqsm5gflwrnw84gwbf5x1hkkrvgysmjfygvkgg3n1zv1w"))
        (file-name (string-append name "-" version ".tar.gz"))))
     (build-system haskell-build-system)
     (arguments
@@ -852,7 +853,11 @@  (define-public shellcheck
     (native-inputs
      (list pandoc))
     (inputs
-     (list ghc-aeson ghc-diff ghc-quickcheck ghc-regex-tdfa))
+     (list ghc-aeson
+           ghc-diff
+           ghc-fgl
+           ghc-quickcheck
+           ghc-regex-tdfa))
     (home-page "https://www.shellcheck.net/")
     (synopsis "Static analysis for shell scripts")
     (description "@code{shellcheck} provides static analysis for