diff mbox series

[bug#60008] gnu: Add raylib.

Message ID 20221212235911.30300-1-i@dan.games
State New
Headers show
Series [bug#60008] gnu: Add raylib. | expand

Commit Message

dan Dec. 12, 2022, 11:59 p.m. UTC
* gnu/packages/game-development.scm (raylib): New variable.
---
 gnu/packages/game-development.scm | 33 +++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

Comments

Ludovic Courtès Jan. 17, 2023, 2:50 p.m. UTC | #1
Hi,

dan <i@dan.games> skribis:

> * gnu/packages/game-development.scm (raylib): New variable.

Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 4a0435045b..7bdc6a8818 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -27,6 +27,7 @@ 
 ;;; Copyright © 2021 Andy Tai <atai@atai.org>
 ;;; Copyright © 2022 Felix Gruber <felgru@posteo.net>
 ;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
+;;; Copyright © 2022 dan <i@dan.games>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2866,3 +2867,35 @@  (define-public recastnavigation
 progresses the level, or you may regenerate tiles as the world changes.")
       (home-page "https://github.com/recastnavigation/recastnavigation")
       (license license:zlib))))
+
+(define-public raylib
+  (package
+    (name "raylib")
+    (version "4.2.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/raysan5/raylib/")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "14v5iwxh8grywiyw9agpd2sfpyriq1rwwkd9f2s4iihh0z5j7hk8"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list #:tests? #f)) ;no test
+    (inputs (list alsa-lib
+                  libx11
+                  libxrandr
+                  libxi
+                  libxinerama
+                  libxcursor
+                  mesa))
+    (native-inputs (list pkg-config))
+    (synopsis "C library for videogame programming")
+    (description
+     "raylib is a high-level library for video game programming.  It aims to
+  abstract away platform and graphics details, allowing you to focus on
+  writing your game.")
+    (home-page "https://www.raylib.com/")
+    (license license:zlib)))