diff mbox series

[bug#59978,4/6] gnu: wcslib: Update to 7.12.

Message ID 20221211222545.32318-4-sharlatanus@gmail.com
State New
Headers show
Series gnu: python-astropy: Unbundle WCSLIB. | expand

Commit Message

Sharlatan Hellseher Dec. 11, 2022, 10:25 p.m. UTC
* gnu/packages/astronomy.scm (wcslib): Update to 7.12.
  [arguments]: Use Gexp, enable parallel tests.
---
 gnu/packages/astronomy.scm | 34 +++++++++++++++++-----------------
 1 file changed, 17 insertions(+), 17 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 5ce94a1f07..1876b0cde0 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -525,7 +525,7 @@  (define-public eye
 (define-public wcslib
   (package
     (name "wcslib")
-    (version "7.5")
+    (version "7.12")
     (source
      (origin
        (method url-fetch)
@@ -533,26 +533,26 @@  (define-public wcslib
              "ftp://ftp.atnf.csiro.au/pub/software/wcslib/wcslib-" version
              ".tar.bz2"))
        (sha256
-        (base32 "1536gmcpm6pckn9xrb6j8s4pm1vryjhzvhfaj9wx3jwxcpbdy0dw"))))
+        (base32 "1m3bx6gh5w3c7vvsqcki0x20mg8lilg13m0i8nh7za89w58dxy4w"))))
     (inputs
      (list cfitsio))
     (build-system gnu-build-system)
     (arguments
-     `(#:configure-flags
-       (list (string-append "--with-cfitsiolib="
-                            (assoc-ref %build-inputs "cfitsio") "/lib")
-             (string-append "--with-cfitsioinc="
-                            (assoc-ref %build-inputs "cfitsio") "/include"))
-       #:phases
-       (modify-phases %standard-phases
-         (add-before 'configure 'patch-/bin/sh
-           (lambda _
-             (substitute* "makedefs.in"
-               (("/bin/sh") "sh"))
-             #t))
-         (delete 'install-license-files)) ; installed by ‘make install’
-       ;; Parallel execution of the test suite is not supported.
-       #:parallel-tests? #f))
+     (list
+      #:configure-flags
+      #~(list (string-append "--with-cfitsiolib="
+                             #$(this-package-input "cfitsio") "/lib")
+              (string-append "--with-cfitsioinc="
+                             #$(this-package-input "cfitsio") "/include"))
+      #:phases
+      #~(modify-phases %standard-phases
+          (delete 'install-license-files) ; installed by ‘make install’
+          (add-before 'configure 'patch-/bin/sh
+            (lambda _
+              (substitute* "makedefs.in"
+                (("/bin/sh") "sh")))))))
+    ;; TODO: Fix build with gfortran and pack missing optional pgplot.
+    ;; (inputs (list gfortran pgplot))
     (home-page "https://www.atnf.csiro.au/people/mcalabre/WCS")
     (synopsis "Library which implements the FITS WCS standard")
     (description "The FITS \"World Coordinate System\" (@dfn{WCS}) standard