diff mbox series

[bug#59908,1/4] gnu: Add r-rcppde.

Message ID 20221208192232.16413-1-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#59908,1/4] gnu: Add r-rcppde. | expand

Commit Message

Mădălin Ionel Patrașcu Dec. 8, 2022, 7:22 p.m. UTC
* gnu/packages/cran.scm (r-rcppde): New variable.
---
 gnu/packages/cran.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)


base-commit: 81191e3410cc00c6438f532599dd0b96d521982f

Comments

Ricardo Wurmus Dec. 12, 2022, 5:44 p.m. UTC | #1
Thanks for the patches.  I applied them with negligible formatting
changes.
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 5c5258d6e0..016eeb4821 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4569,6 +4569,32 @@  (define-public r-rcpp
 @code{citation(\"Rcpp\")} for details on these last two.")
     (license license:gpl2+)))
 
+(define-public r-rcppde
+  (package
+    (name "r-rcppde")
+    (version "0.1.6")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "RcppDE" version))
+              (sha256
+               (base32
+                "1i9jj595nqpb16y22z2b8fcf0gq1fg0pbiisbd837p1cyw4nff69"))))
+    (properties `((upstream-name . "RcppDE")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-rcpp
+           r-rcpparmadillo))
+    (home-page "https://cran.r-project.org/package=RcppDE")
+    (synopsis "Global optimization by differential evolution in C++")
+    (description
+     "This package provides an iteration of the @code{DEoptim} function.  It
+performs global optimization by differential evolution.  The implementation
+employs the @code{Rcpp} package.  The last one provides tools for integration
+of R objects at the C++ level—and vice versa.  @code{R-rcppde} uses the @code{
+RcppArmadillo} package.  This one provides an interface from R to the Armadillo
+linear algebra package written in C++.")
+    (license license:gpl2+)))
+
 (define-public r-rcppml
   (package
     (name "r-rcppml")