diff mbox series

[bug#59892] gnu: Add python-poppy.

Message ID 20221208000259.18624-1-sharlatanus@gmail.com
State New
Headers show
Series [bug#59892] gnu: Add python-poppy. | expand

Commit Message

Sharlatan Hellseher Dec. 8, 2022, 12:02 a.m. UTC
* gnu/packages/astronomy.scm (python-poppy): New variable.
---
 gnu/packages/astronomy.scm | 45 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 45 insertions(+)

Comments

Sharlatan Hellseher Jan. 13, 2023, 9:55 p.m. UTC | #1
Hi Ludo,

Thanks for merging updates for Astropy and related packages in #59978.
I see that the Science group where Astronomy is listed in scope has no
members that's why I mention you on this issue :)

QA is green it's just one more Astro packages to Guix collection, let
me know if I need to update anything on the patch.

Regards,
Oleg

-- 
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
Maxim Cournoyer Jan. 16, 2023, 5:14 p.m. UTC | #2
Hi,

Sharlatan Hellseher <sharlatanus@gmail.com> writes:

> * gnu/packages/astronomy.scm (python-poppy): New variable.

LGTM!  Applied, thanks for your contribution.
diff mbox series

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index c59f4d02a4..fb00a90129 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -66,6 +66,7 @@  (define-module (gnu packages astronomy)
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages qt)
   #:use-module (gnu packages readline)
+  #:use-module (gnu packages sphinx)
   #:use-module (gnu packages textutils)
   #:use-module (gnu packages time)
   #:use-module (gnu packages version-control)
@@ -1336,6 +1337,50 @@  (define-public python-photutils
 of astronomical sources.")
     (license license:bsd-3)))
 
+(define-public python-poppy
+  (package
+    (name "python-poppy")
+    (version "1.0.3")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "poppy" version))
+              (sha256
+               (base32
+                "050cn6aabd1dxbi7zihbqnkl79hz6q6d5n6g25zmrpvc4sii171m"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs
+     ;; XXX: With python-synphot (marked as optional) package added to the list
+     ;; it tries to download from remote host during tests and fails. Overall
+     ;; tests take up to 5-8min to pass.
+     (list python-astropy
+           python-matplotlib
+           python-numpy
+           python-scipy))
+    (native-inputs
+     (list python-docutils
+           python-h5py
+           python-pandas
+           python-pytest
+           python-pytest-astropy
+           python-sphinx
+           python-setuptools-scm))
+    (home-page "https://poppy-optics.readthedocs.io/")
+    (synopsis "Physical Optics Propagation in Python")
+    (description
+     "@acronym{POPPY, Physical Optics Propagation in Python} is a Python package that
+simulates physical optical propagation including diffraction.  It implements a
+flexible framework for modeling Fraunhofer and Fresnel diffraction and point
+spread function formation, particularly in the context of astronomical
+telescopes.
+
+POPPY was developed as part of a simulation package for the James Webb Space
+Telescope, but is more broadly applicable to many kinds of imaging simulations.
+It is not, however, a substitute for high fidelity optical design software such
+as Zemax or Code V, but rather is intended as a lightweight alternative for
+cases for which diffractive rather than geometric optics is the topic of
+interest, and which require portability between platforms or ease of scripting.")
+    (license license:bsd-3)))
+
 (define-public python-pyvo
   (package
     (name "python-pyvo")