diff mbox series

[bug#59898] gnu: nethack: Fix missing command line argument support in wrapper.

Message ID 20221207183750.6193-1-ron@noisytoot.org
State New
Headers show
Series [bug#59898] gnu: nethack: Fix missing command line argument support in wrapper. | expand

Commit Message

Ron Nazarov Dec. 7, 2022, 6:37 p.m. UTC
* gnu/packages/games.scm (nethack): Fix missing command line argument support in wrapper.
---
 gnu/packages/games.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

宋文武 Dec. 9, 2022, 2:36 a.m. UTC | #1
Ron Nazarov <ron@noisytoot.org> writes:

> * gnu/packages/games.scm (nethack): Fix missing command line argument support in wrapper.

Applied with small modification of commit message, thank you!
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 0f5f3cc332..3dd056e1eb 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -63,7 +63,7 @@ 
 ;;; Copyright © 2021 David Pflug <david@pflug.io>
 ;;; Copyright © 2021, 2022 Felix Gruber <felgru@posteo.net>
 ;;; Copyright © 2021 Solene Rapenne <solene@perso.pw>
-;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
+;;; Copyright © 2021, 2022 Noisytoot <ron@noisytoot.org>
 ;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
 ;;; Copyright © 2021, 2022 Brendan Tildesley <mail@brendan.scot>
 ;;; Copyright © 2021 Christopher Baines <mail@cbaines.net>
@@ -2086,7 +2086,7 @@  (define-public nethack
 for i in ~a/games/lib/nethackdir/*; do
   ln -s $i $(basename $i)
 done
-~a/games/nethack"
+~a/games/nethack \"$@\""
                       (assoc-ref %build-inputs "bash")
                       (list->search-path-as-string
                         (list