diff mbox series

[bug#59865] gnu: Add ghc-parsec.

Message ID 20221206225946.27435-1-jgart@dismail.de
State New
Headers show
Series [bug#59865] gnu: Add ghc-parsec. | expand

Commit Message

jgart Dec. 6, 2022, 10:59 p.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-parsec): New variable.
---
 gnu/packages/haskell-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Christopher Baines Jan. 11, 2023, 10:59 a.m. UTC | #1
jgart via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/haskell-xyz.scm (ghc-parsec): New variable.
> ---
>  gnu/packages/haskell-xyz.scm | 24 ++++++++++++++++++++++++
>  1 file changed, 24 insertions(+)

Thanks, I've pushed this to master as
a8b2decf287498eeb51ef23712c5bd01b60cb18b.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 2b92600806..7320b72744 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -9215,6 +9215,30 @@  (define-public ghc-parallel
      "This package provides a library for parallel programming.")
     (license license:bsd-3)))
 
+(define-public ghc-parsec
+  (package
+    (name "ghc-parsec")
+    (version "3.1.14.0")
+    (source (origin
+              (method url-fetch)
+              (uri (hackage-uri "parsec" version))
+              (sha256
+               (base32
+                "132waj2cpn892midbhpkfmb74qq83v0zv29v885frlp1gvh94b67"))))
+    (build-system haskell-build-system)
+    (native-inputs (list ghc-hunit ghc-test-framework ghc-test-framework-hunit))
+    (arguments
+     `(#:cabal-revision ("4"
+                         "0p65q054iaz2117a5qk1428dic4sb41acclys9k00zna24ks7iq3")))
+    (home-page "https://github.com/haskell/parsec")
+    (synopsis "Monadic parser combinators")
+    (description "Parsec is designed from scratch as an industrial-strength parser
+library.  It is simple, safe, well documented (on the package homepage),
+has extensive libraries, good error messages, and is fast.  It is defined
+as a monad transformer that can be stacked on arbitrary monads, and it
+is also parametric in the input stream type.")
+    (license license:bsd-3)))
+
 (define-public ghc-parsec-numbers
   (package
     (name "ghc-parsec-numbers")