diff mbox series

[bug#58437,1/2,v2] gnu: python-trezor: Update to 0.13.3.

Message ID 20221206180425.26026-1-attila@lendvai.name
State New
Headers show
Series [bug#58437,1/2,v2] gnu: python-trezor: Update to 0.13.3. | expand

Commit Message

Attila Lendvai Dec. 6, 2022, 6:04 p.m. UTC
Also disable the sanity-check phase.
---

the sanity-check removal is in the same commit, because it became
needed due to the version update.

 gnu/packages/finance.scm | 22 +++++++++++++---------
 1 file changed, 13 insertions(+), 9 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index cc2d417003..287ee38041 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1054,7 +1054,7 @@  (define-public python-btchip-python
 (define-public python-trezor
   (package
     (name "python-trezor")
-    (version "0.13.0")
+    (version "0.13.3")
     (source
      (origin
        (method git-fetch)
@@ -1063,7 +1063,7 @@  (define-public python-trezor
              (commit (string-append "python/v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1wy584bxx5p2av4lv1bx9hl1q0b5n7hqz0hnqb9shjriarvl5ckd"))
+        (base32 "18qbdypi780b2s933dp7msh9m17mx9nq6qxn87jkwlf4i94h1vr2"))
        (modules
         '((guix build utils)
           (srfi srfi-26)
@@ -1089,10 +1089,7 @@  (define-public python-trezor
     (build-system python-build-system)
     (propagated-inputs
      (list python-attrs
-           ;; TOOD: Use the latest click version after release 0.13.1 or later
-           ;; is made (see:
-           ;; https://github.com/trezor/trezor-firmware/issues/2199).
-           python-click-7
+           python-click
            python-construct
            python-ecdsa
            python-hidapi
@@ -1100,14 +1097,21 @@  (define-public python-trezor
            python-mnemonic
            python-requests
            python-typing-extensions))
-    (native-inputs
-     ;; For tests.
+    (native-inputs ; Only needed for running the tests
      (list protobuf
            python-black
            python-isort
+           python-pillow
            python-protobuf
            python-pyqt
-           python-pytest))
+           python-pytest
+           python-simple-rlp))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         ;; This package only has a Python script, not a Python module, so the
+         ;; sanity-check phase can't work.
+         (delete 'sanity-check))))
     (home-page "https://github.com/trezor/python-trezor")
     (synopsis "Python library for communicating with TREZOR Hardware Wallet")
     (description "@code{trezor} is a Python library for communicating with