diff mbox series

[bug#59845,2/4] gnu: Add PMB.

Message ID 20221205215224.27623-2-yarl-baudig@mailoo.org
State New
Headers show
Series Add PMB (Integrated Library System) | expand

Commit Message

yarl baudig Dec. 5, 2022, 9:52 p.m. UTC
* gnu/packages/ils.scm: New file.
* gnu/local.mk: Add it.
---
 gnu/local.mk         |  1 +
 gnu/packages/ils.scm | 61 ++++++++++++++++++++++++++++++++++++++++++++
 2 files changed, 62 insertions(+)
 create mode 100644 gnu/packages/ils.scm
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 1bfbe28bde..ff0c86584a 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -323,6 +323,7 @@  GNU_SYSTEM_MODULES =				\
   %D%/packages/icu4c.scm			\
   %D%/packages/idris.scm			\
   %D%/packages/idutils.scm			\
+  %D%/packages/ils.scm				\
   %D%/packages/image.scm			\
   %D%/packages/image-processing.scm	\
   %D%/packages/image-viewers.scm	\
diff --git a/gnu/packages/ils.scm b/gnu/packages/ils.scm
new file mode 100644
index 0000000000..3f3eb0705a
--- /dev/null
+++ b/gnu/packages/ils.scm
@@ -0,0 +1,61 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2022 Yarl Baudig <yarl-baudig@mailoo.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages ils)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system copy)
+  #:use-module (guix licenses)
+  #:use-module (gnu packages gawk)
+  #:use-module (gnu packages compression)
+  #:use-module (gnu packages php)
+  #:use-module (gnu packages perl))
+
+;;; Commentary
+;;;
+;;; Integrated Library Systems packages.
+;;;
+;;; Code
+
+(define-public pmb
+  (package
+   (name "pmb")
+   (version "7.4.6")
+   (source (origin
+            (method url-fetch)
+            (uri
+	     (string-append
+	      "https://forge.sigb.net/attachments/download/3968/pmb"
+	      version
+              ".zip"))
+            (sha256
+             (base32
+              "0ana1w8d60n2gznhh1zyjdld4xi4p2pm2hc05m8n7fh2bvlmw0cr"))))
+   (build-system copy-build-system)
+   (arguments '(#:install-plan '(("." "share/http/pmb"))))
+   (native-inputs (list unzip))
+   (propagated-inputs (list php perl))
+   (synopsis "Integrated Library System")
+   (description "PMB is an Integrated Library System for librarians, documentalists and
+information managers.
+
+This contains only the PMB archive (html, php and css files), you will need a web
+server, php and a SQL database server. See the guix pmb service.")
+   (home-page "https://www.sigb.net")
+   (license cecill)))
+