diff mbox series

[bug#59764,2/8] gnu: Add python-greenlet.

Message ID 20221202055919.58982-2-kiasoc5@disroot.org
State New
Headers show
Series Update searx and dependencies | expand

Commit Message

kiasoc5 Dec. 2, 2022, 5:59 a.m. UTC
* gnu/packages/python-xyz.scm (python-greenlet): New variable.
---
 gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 17fbd9de9e..2e1db8a252 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12370,6 +12370,28 @@  (define-public python-curio
 tasks, sockets, files, locks, and queues.")
     (license license:bsd-3)))
 
+(define-public python-greenlet
+(package
+  (name "python-greenlet")
+  (version "2.0.1")
+  (source (origin
+            (method url-fetch)
+            (uri (pypi-uri "greenlet" version))
+            (sha256
+             (base32
+              "0rqgxp1fai0fcyv46nd1389mxvk3ccixgdkwws70xnk08ib05rj2"))))
+  (build-system python-build-system)
+  (native-inputs (list python-objgraph python-psutil))
+  (home-page "https://greenlet.readthedocs.io/")
+  (synopsis "Lightweight in-process concurrent programming")
+  (description
+    "This package provides greenlets for Python.  greenlets are lightweight
+coroutines for in-process sequential concurrent programming.  They are
+frequently used with frameworks such as gevent to provide higher-level
+abstractions and asynchronous I/O.  They are analagous to threads or Python's
+built-in coroutines.")
+  (license license:expat)))
+
 (define-public python-tables
   (package
     (name "python-tables")