diff mbox series

[bug#59740,v2] gnu: Add cl-duologue.

Message ID 20221201133835.13235-1-jgart@dismail.de
State New
Headers show
Series [bug#59740,v2] gnu: Add cl-duologue. | expand

Commit Message

jgart Dec. 1, 2022, 1:38 p.m. UTC
* gnu/packages/lisp-xyz.scm (cl-duologue, ecl-duologue, sbcl-duologue):
New variables.

hi,

v2 adds missing paren to sbcl-duologue

all best,

jgart
---
 gnu/packages/lisp-xyz.scm | 41 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 02844cd870..d7dbb77b06 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -255,6 +255,47 @@  (define-public cl-langutils
 (define-public ecl-langutils
   (sbcl-package->ecl-package sbcl-langutils))
 
+(define-public sbcl-duologue
+  (let ((commit "9c31c1761dd1fc009f2f4c6bf47a88826d87498b")
+        (revision "0"))
+    (package
+      (name "sbcl-duologue")
+      (version (git-version "20220605" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/mmontone/duologue")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "03ypcdz4gl8i82ivvnzc5ng4m9b8rkifyl13ik2grlcl5x2wq7ih"))))
+      (build-system asdf-build-system/sbcl)
+      (native-inputs (list sbcl-stefil))
+      (inputs
+        (list sbcl-alexandria
+              sbcl-anaphora
+              sbcl-clavier
+              sbcl-chronicity
+              sbcl-drakma
+              sbcl-cl-ansi-text
+              sbcl-cl-fad))
+      (home-page "https://github.com/mmontone/duologue/")
+      (synopsis "High level user interaction library")
+      (description
+"Duologue is high-level interaction library for Common Lisp.  It features
+coloured printing via @code{cl-ansi-text} and readline completion.")
+      (license (list license:expat
+                     ;; https://github.com/mmontone/duologue/issues/9
+                     license:gpl3+)))))
+
+(define-public cl-duologue
+  (sbcl-package->cl-source-package sbcl-duologue))
+
+;; https://github.com/mmontone/duologue/issues/10
+#;(define-public ecl-duologue
+  (sbcl-package->ecl-package sbcl-duologue))
+
 (define-public sbcl-alea
   (package
     (name "sbcl-alea")