diff mbox series

[bug#59681,1/2] gnu: loko: Use G-expressions.

Message ID 20221129152134.8917-1-all_but_last@163.com
State New
Headers show
Series [bug#59681,1/2] gnu: loko: Use G-expressions. | expand

Commit Message

Zhu Zihao Nov. 29, 2022, 3:21 p.m. UTC
* gnu/packages/loko.scm (loko)[arguments]: Use G-expressions.
<#:phases>: In 'akku-fixes', replace "(assoc-ref inputs name)" with
"this-package-native-input".
[native-inputs]: Use label-less style.
---
 gnu/packages/loko.scm | 72 +++++++++++++++++++++++--------------------
 1 file changed, 38 insertions(+), 34 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/loko.scm b/gnu/packages/loko.scm
index 449c62f1f0..cb189acb87 100644
--- a/gnu/packages/loko.scm
+++ b/gnu/packages/loko.scm
@@ -41,41 +41,45 @@  (define-public loko-scheme
        (file-name (git-file-name name version))))
     (build-system gnu-build-system)
     (arguments
-     `(;; r7rs tests are a work in progress as of 0.7.0.
-       #:tests? #f
-       #:strip-binaries? #f
-       #:make-flags
-       (let ((out (assoc-ref %outputs "out")))
-         (list
-          (string-append "PREFIX=" out)
-          (string-append "GDB_AUTOLOAD_PATH=" out "/share/gdb/auto-load")))
-       #:phases
-       (modify-phases %standard-phases
-         (delete 'configure)
-         (add-before 'build 'akku-fixes
-           (lambda* (#:key inputs #:allow-other-keys)
-             (delete-file "Akku.lock")
-             (substitute* "Akku.manifest"
-               (("\\(depends.*") "(depends)"))
-             (invoke "akku" "install")
-             (let ((dest "./.akku/lib/")
-                   (source "/share/guile/site/3.0/"))
-               (for-each
-                (lambda (name)
-                  ;; Symlink the scheme libraries so that Akku can find them
-                  (symlink (string-append (assoc-ref inputs name) source name)
-                           (string-append dest name)))
-                '("struct" "laesare" "pfds" "machine-code")))
-             (substitute* ".akku/env"
-               (("/bin/sh") (which "sh")))
-             #t)))))
+     (list
+      ;; r7rs tests are a work in progress as of 0.7.0.
+      #:tests? #f
+      #:strip-binaries? #f
+      #:make-flags
+      #~(list
+         (string-append "PREFIX=" #$output)
+         (string-append "GDB_AUTOLOAD_PATH=" #$output "/share/gdb/auto-load"))
+      #:phases
+      #~(modify-phases %standard-phases
+          (delete 'configure)
+          (add-before 'build 'akku-fixes
+            (lambda _
+              (delete-file "Akku.lock")
+              (substitute* "Akku.manifest"
+                (("\\(depends.*") "(depends)"))
+              (invoke "akku" "install")
+              (let ((dest "./.akku/lib/")
+                    (source "/share/guile/site/3.0/"))
+                (for-each
+                 (lambda (name prefix)
+                   ;; Symlink the scheme libraries so that Akku can find them
+                   (symlink (string-append prefix source name)
+                            (string-append dest name)))
+                 '("struct" "laesare" "pfds" "machine-code")
+                 (list #$(this-package-native-input "guile-struct-pack")
+                       #$(this-package-native-input "guile-laesare")
+                       #$(this-package-native-input "guile-pfds")
+                       #$(this-package-native-input "guile-machine-code"))))
+              (substitute* ".akku/env"
+                (("/bin/sh") (which "sh")))
+              #t)))))
     (native-inputs
-     `(("akku" ,akku)
-       ("chez-scheme" ,(chez-scheme-for-system))
-       ("struct" ,guile-struct-pack)
-       ("laesare" ,guile-laesare)
-       ("pfds" ,guile-pfds)
-       ("machine-code" ,guile-machine-code)))
+     (list akku
+           (chez-scheme-for-system)
+           guile-struct-pack
+           guile-laesare
+           guile-pfds
+           guile-machine-code))
     (home-page "https://scheme.fail")
     (synopsis "Implementation of the algorithmic language Scheme")
     (description