diff mbox series

[bug#59672] gnu: Add r-metaneighbor.

Message ID 20221129080056.16623-1-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#59672] gnu: Add r-metaneighbor. | expand

Commit Message

Mădălin Ionel Patrașcu Nov. 29, 2022, 8 a.m. UTC
* gnu/packages/bioconductor.scm (r-metaneighbor): New variable.
---
 gnu/packages/bioconductor.scm | 36 +++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)


base-commit: 3578fb1323db3f0eadd5749e51095e5f196d78c7

Comments

Ricardo Wurmus Dec. 1, 2022, 10:50 a.m. UTC | #1
Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 39c9c6f809..c3e0548b45 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -6010,6 +6010,42 @@  (define-public r-made4
 datasets (coinertia analysis).")
     (license license:artistic2.0)))
 
+(define-public r-metaneighbor
+  (package
+    (name "r-metaneighbor")
+    (version "1.18.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "MetaNeighbor" version))
+              (sha256
+               (base32
+                "1gjjp5qlmv26sd3fvrd8cgv3invckxr8ldjpizpqm4mxjzifxwpm"))))
+    (properties `((upstream-name . "MetaNeighbor")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-beanplot
+           r-dplyr
+           r-ggplot2
+           r-gplots
+           r-igraph
+           r-matrix
+           r-matrixstats
+           r-rcolorbrewer
+           r-singlecellexperiment
+           r-summarizedexperiment
+           r-tibble
+           r-tidyr))
+    (native-inputs (list r-knitr))
+    (home-page "https://bioconductor.org/packages/MetaNeighbor")
+    (synopsis "Single cell replicability analysis")
+    (description
+     "This package implements a method to rapidly assess cell type identity using
+both functional and random gene sets and it allows users to quantify cell type
+replicability across datasets using neighbor voting.  @code{MetaNeighbor} works
+on the basis that cells of the same type should have more similar gene expression
+profiles than cells of different types.")
+    (license license:expat)))
+
 (define-public r-methylkit
   (package
     (name "r-methylkit")