diff mbox series

[bug#59190,v2] gnu: Add python-pytest-parawtf.

Message ID 20221129053424.3030-1-jgart@dismail.de
State New
Headers show
Series [bug#59190,v2] gnu: Add python-pytest-parawtf. | expand

Commit Message

jgart Nov. 29, 2022, 5:34 a.m. UTC
* gnu/packages/python-check.scm (python-pytest-parawtf): New variable.

Hi Ludo and Efraim. Here's v2.

I disabled the failing parametrized tests and added a comment to a
pending issue I opened with upstream regarding fixing the failing tests.

all best,

jgart

---
 gnu/packages/python-check.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

Comments

Efraim Flashner Nov. 29, 2022, 7:23 a.m. UTC | #1
Thanks. Patch pushed!
diff mbox series

Patch

diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 749902271b..486abf1c13 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -16,6 +16,7 @@ 
 ;;; Copyright © 2022 Malte Frank Gerdes <malte.f.gerdes@gmail.com>
 ;;; Copyright © 2022 Felix Gruber <felgru@posteo.net>
 ;;; Copyright © 2022 Tomasz Jeneralczyk <tj@schwi.pl>
+;;; Copyright © 2022 jgart <jgart@dismail.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2439,6 +2440,34 @@  (define-public python-sybil
 provided for the main Python test runners.")
     (license license:expat)))
 
+(define-public python-pytest-parawtf
+  (package
+    (name "python-pytest-parawtf")
+    (version "1.0.2")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "pytest-parawtf" version))
+              (sha256
+               (base32
+                "08s86hy58lvrd90cnayzydvac4slaflj0ph9yknakcc42anrm023"))))
+    (build-system python-build-system)
+    (arguments
+     (list
+       #:phases
+       #~(modify-phases %standard-phases
+           (replace 'check
+             (lambda* (#:key tests? #:allow-other-keys)
+               (when tests?
+                 ;; https://github.com/flub/pytest-parawtf/issues/1
+                 (invoke "pytest" "-k" "not test_mark")))))))
+    (propagated-inputs (list python-pytest))
+    (home-page "https://github.com/flub/pytest-parawtf/")
+    (synopsis "Finally spell paramete?ri[sz]e correctly")
+    (description
+"@code{python-pytest} uses one of four different spellings of
+parametrize.  This plugin allows you to use all four.")
+    (license license:expat)))
+
 (define-public python-pytest-httpx
   (package
     (name "python-pytest-httpx")