diff mbox series

[bug#59649] gnu: Add emacs-ibrowse.

Message ID 20221128080733.28777-1-ngraves@ngraves.fr
State New
Headers show
Series [bug#59649] gnu: Add emacs-ibrowse. | expand

Commit Message

Nicolas Graves Nov. 28, 2022, 8:07 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-ibrowse): New variable.
---
 gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Andrew Tropin Nov. 28, 2022, 11:12 a.m. UTC | #1
On 2022-11-28 09:07, Nicolas Graves wrote:

> * gnu/packages/emacs-xyz.scm (emacs-ibrowse): New variable.
> ---
>  gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
>  1 file changed, 24 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 35d6d87030..a680b29f27 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -21515,6 +21515,30 @@ (define-public emacs-mbsync
>  within Emacs.")
>        (license license:gpl3+))))
>  
> +(define-public emacs-ibrowse
> +  (let* ((commit "7e4a2987fc63861514b441f65db2008da5949ef2")
> +         (revision "0"))
> +    (package
> +      (name "emacs-ibrowse")
> +      (version (git-version "0.0" revision commit))
> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri (git-reference
> +               (url "https://git.sr.ht/~ngraves/ibrowse.el")
> +               (commit commit)))
> +         (file-name (git-file-name name version))
> +         (sha256
> +          (base32 "15661xgjxdxk1p0g87dsas9jd9v7g64y6n9irlbyzww09gjsjwwd"))))
> +      (build-system emacs-build-system)
> +      (inputs (list sqlite))
> +      (propagated-inputs (list emacs-embark emacs-marginalia))
> +      (home-page "https://git.sr.ht/~ngraves/ibrowse.el")
> +      (synopsis "Interact with your browser from emacs")
> +      (description "This package provides some commands to act on the browser
> +tabs, history, or bookmarks from Emacs.")
> +      (license license:gpl3+))))
> +
>  (define-public emacs-ibuffer-projectile
>    (package
>      (name "emacs-ibuffer-projectile")

Could you add a version tag and use it in package definition, please?
Ludovic Courtès Jan. 5, 2023, 9:21 p.m. UTC | #2
Hi,

Nicolas Graves <ngraves@ngraves.fr> skribis:

> * gnu/packages/emacs-xyz.scm (emacs-ibrowse): New variable.

Not sure what Andrew had in mind regarding a “version tag” (seems
alright to me, no?) so I went ahead and finally applied it.

Thanks!

Ludo’.
Andrew Tropin Jan. 6, 2023, 8:27 a.m. UTC | #3
On 2023-01-05 22:21, Ludovic Courtès wrote:

> Hi,
>
> Nicolas Graves <ngraves@ngraves.fr> skribis:
>
>> * gnu/packages/emacs-xyz.scm (emacs-ibrowse): New variable.
>
> Not sure what Andrew had in mind regarding a “version tag” (seems
> alright to me, no?) so I went ahead and finally applied it.

Nicolas is an author of the ibrowse and has a write access to the repo,
so I asked to add a tag, so we can reference it in guix package
definition instead of commit =)
Ludovic Courtès Jan. 6, 2023, 11:04 p.m. UTC | #4
Andrew Tropin <andrew@trop.in> skribis:

> On 2023-01-05 22:21, Ludovic Courtès wrote:
>
>> Hi,
>>
>> Nicolas Graves <ngraves@ngraves.fr> skribis:
>>
>>> * gnu/packages/emacs-xyz.scm (emacs-ibrowse): New variable.
>>
>> Not sure what Andrew had in mind regarding a “version tag” (seems
>> alright to me, no?) so I went ahead and finally applied it.
>
> Nicolas is an author of the ibrowse and has a write access to the repo,
> so I asked to add a tag, so we can reference it in guix package
> definition instead of commit =)

Ooh, I didn’t know that, sorry!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 35d6d87030..a680b29f27 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21515,6 +21515,30 @@  (define-public emacs-mbsync
 within Emacs.")
       (license license:gpl3+))))
 
+(define-public emacs-ibrowse
+  (let* ((commit "7e4a2987fc63861514b441f65db2008da5949ef2")
+         (revision "0"))
+    (package
+      (name "emacs-ibrowse")
+      (version (git-version "0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://git.sr.ht/~ngraves/ibrowse.el")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "15661xgjxdxk1p0g87dsas9jd9v7g64y6n9irlbyzww09gjsjwwd"))))
+      (build-system emacs-build-system)
+      (inputs (list sqlite))
+      (propagated-inputs (list emacs-embark emacs-marginalia))
+      (home-page "https://git.sr.ht/~ngraves/ibrowse.el")
+      (synopsis "Interact with your browser from emacs")
+      (description "This package provides some commands to act on the browser
+tabs, history, or bookmarks from Emacs.")
+      (license license:gpl3+))))
+
 (define-public emacs-ibuffer-projectile
   (package
     (name "emacs-ibuffer-projectile")