diff mbox series

[bug#59640] gnu: Add tilix.

Message ID 20221127185348.10186-1-jgart@dismail.de
State New
Headers show
Series [bug#59640] gnu: Add tilix. | expand

Commit Message

jgart Nov. 27, 2022, 6:53 p.m. UTC
* gnu/packages/terminals.scm (tilix): New variable.
---
 gnu/packages/terminals.scm | 43 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)

Comments

jgart Nov. 27, 2022, 7:10 p.m. UTC | #1
On Sun, 27 Nov 2022 18:55:02 +0000 help-debbugs@gnu.org (GNU bug Tracking System) wrote:

Ignore v1. Waiting on gtkd getting patched because it is currently broken.

I just added this here to share my tilix WIP with others and to get feedback.
Christopher Baines Dec. 13, 2022, 1:24 p.m. UTC | #2
jgart via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/terminals.scm (tilix): New variable.
> ---
>  gnu/packages/terminals.scm | 43 ++++++++++++++++++++++++++++++++++++++
>  1 file changed, 43 insertions(+)

Hey, thanks for the patch.

> +    (source
> +      (origin
> +        (method git-fetch)
> +        (uri (git-reference
> +               (url "https://github.com/gnunn1/tilix")
> +               (commit version)))
> +        (file-name (git-file-name name version))
> +       (sha256
> +        (base32 "0sb1hypg2276y8c2a5vivrkcxp70swddvhnd9h273if3kv6j879r"))))

This hash doesn't seem to match, you can sort of see this with the QA
testing. Has something changed upstream since you prepared the patch?

> +    (build-system meson-build-system)
> +    (arguments
> +      '(#:glib-or-gtk? #t
> +        #:configure-flags '("-Dbuildtype=debugoptimized")
> +        #:phases
> +        (modify-phases %standard-phases 
> +            (delete 'check))))
> +    (inputs
> +     (list dbus
> +           gettext-minimal
> +           dconf
> +           gsettings-desktop-schemas
> +           libsecret
> +           libunwind))
> +    (native-inputs
> +      (list desktop-file-utils
> +            gtkd

Also, gtkd seems to fail to build for me, so I can't build tilix. Were
you able to build it locally?

Thanks,

Chris
jgart Dec. 13, 2022, 4:23 p.m. UTC | #3
On Tue, 13 Dec 2022 13:24:02 +0000 Christopher Baines <mail@cbaines.net> wrote:
> Also, gtkd seems to fail to build for me, so I can't build tilix. Were
> you able to build it locally?

Hi Christopher,

Sorry to not update this patch. I haven't had time to work on gtkd but
I'll send an update to both gtkd and tilix once I fix the former.

Thanks for the reviews. They are greatly appreciated!

all best,

jgart
diff mbox series

Patch

diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index f6673388d2..69b982a727 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -32,6 +32,7 @@ 
 ;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
 ;;; Copyright © 2022 Felipe Balbi <balbi@kernel.org>
 ;;; Copyright © 2022 ( <paren@disroot.org>
+;;; Copyright © 2022 jgart <jgart@dismail.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -72,6 +73,7 @@  (define-module (gnu packages terminals)
   #:use-module (gnu packages crates-io)
   #:use-module (gnu packages crates-graphics)
   #:use-module (gnu packages crypto)
+  #:use-module (gnu packages dlang)
   #:use-module (gnu packages docbook)
   #:use-module (gnu packages fontutils)
   #:use-module (gnu packages freedesktop)
@@ -86,6 +88,7 @@  (define-module (gnu packages terminals)
   #:use-module (gnu packages image)
   #:use-module (gnu packages libcanberra)
   #:use-module (gnu packages libevent)
+  #:use-module (gnu packages libunwind)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages man)
   #:use-module (gnu packages ncurses)
@@ -1307,6 +1310,46 @@  (define-public eternalterminal
 (define-public wterm
   (deprecated-package "wterm" foot))
 
+(define-public tilix
+  (package
+    (name "tilix")
+    (version "1.9.5")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/gnunn1/tilix")
+               (commit version)))
+        (file-name (git-file-name name version))
+       (sha256
+        (base32 "0sb1hypg2276y8c2a5vivrkcxp70swddvhnd9h273if3kv6j879r"))))
+    (build-system meson-build-system)
+    (arguments
+      '(#:glib-or-gtk? #t
+        #:configure-flags '("-Dbuildtype=debugoptimized")
+        #:phases
+        (modify-phases %standard-phases 
+            (delete 'check))))
+    (inputs
+     (list dbus
+           gettext-minimal
+           dconf
+           gsettings-desktop-schemas
+           libsecret
+           libunwind))
+    (native-inputs
+      (list desktop-file-utils
+            gtkd
+            ldc
+            pkg-config
+            python-wrapper
+            appstream))
+    (home-page "https://gnunn1.github.io/tilix-web/")
+    (synopsis "Tiling terminal emulator following the Gnome Human Interface Guidelines")
+    (description "Tilix is a tiling terminal emulator following the
+Gnome Human Interface Guidelines.")
+    (license license:mpl2.0)))
+
 (define-public tio
   (package
     (name "tio")