diff mbox series

[bug#59567] Added a new package, which is called r-btools. The package is a suite of R function for all types of microbial diversity analyses.

Message ID 20221125100305.25836-1-navid.afkhami@mdc-berlin.de
State New
Headers show
Series [bug#59567] Added a new package, which is called r-btools. The package is a suite of R function for all types of microbial diversity analyses. | expand

Commit Message

Navid Afkhami Nov. 25, 2022, 10:03 a.m. UTC
---
 gnu/packages/bioinformatics.scm | 36 +++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)

Comments

Ricardo Wurmus Nov. 25, 2022, 10:19 a.m. UTC | #1
Thanks for the patch!  I applied it with a few minor changes.  See
commit b095dac8e0aeb9a61ecffd53bfa6f60f49b31f54 for details.
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 6d7097c42c..448d0689a4 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -23,6 +23,7 @@ 
 ;;; Copyright © 2021 Hong Li <hli@mdc-berlin.de>
 ;;; Copyright © 2021, 2022 Simon Tournier <zimon.toutoune@gmail.com>
 ;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2022 Navid Afkhami <navid.afkhami@mdc-berlin.de>	
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -535,6 +536,41 @@  (define-public pbcopper
 and utilities for PacBio C++ applications.")
       (license license:bsd-3))))
 
+(define-public r-btools
+  (let ((commit "fa21d4ca01d37ea4d98b45582453f3bf95cbc2b5")
+        (revision "1"))
+    (package
+      (name "r-btools")
+      (version (git-version "0.0.1" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/twbattaglia/btools")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0bca593dnxz6xdywpdi0ipli0paln2b3bfxxj0csnmj55ryrz428"))))
+      (properties `((upstream-name . "btools")))
+      (build-system r-build-system)
+      (propagated-inputs (list r-biomformat
+                               r-coin
+                               r-deseq2
+                               r-dplyr
+                               r-genefilter
+                               r-phyloseq
+                               r-picante
+                               r-plotly
+                               r-reshape2
+                               r-stringr
+                               r-vegan))
+      (home-page "https://github.com/twbattaglia/btools")
+      (synopsis "R functiones for microbial diversity analyses")
+      (description
+       "An assortment of R functions that ist suitable
+for all types of microbial diversity analyses")
+      (license license:expat))))
+
 (define-public pbbam
   (package
     (name "pbbam")