diff mbox series

[bug#59555] gnu: Add emacs-org-rainbow-tags.

Message ID 20221125012039.14081-1-hako@ultrarare.space
State New
Headers show
Series [bug#59555] gnu: Add emacs-org-rainbow-tags. | expand

Commit Message

Hilton Chain Nov. 25, 2022, 1:20 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-org-rainbow-tags): New variable.
---
 gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Nicolas Goaziou Nov. 26, 2022, 10:42 a.m. UTC | #1
Hello,

Hilton Chain via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-org-rainbow-tags): New variable.

Thank you.

> +      (synopsis
> +       "Colorize org tags automatically to make them visually distinguishable")

I think "Colorize Org tags automatically" is enough as a synopsis.

> +      (description
> +       "This package adds random colors to your org tags. In order to make
> +colors random but consistent between same tags, colors are generated from the
> +hash of the tag names.")

org -> Org

Also, you need to separate sentences with two spaces per Texinfo specifications.

> +      (license license:gpl3))))

License is actually gpl3+ because the main file mentions:

    either version 3 of the License, or ;; (at your option) any later
    version.

Could you send an updated patch?

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a6002efa51..d7bb3213a4 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6105,6 +6105,31 @@  (define-public emacs-org-inline-pdf
 inline PDF preview in Org buffers by using pdf2svg.")
     (license license:gpl3+)))
 
+(define-public emacs-org-rainbow-tags
+  ;; Upstream didn't tag version.
+  (let ((commit "c6040d228c5e8c5c6d33c7f81fc09d935ad1bcbd"))
+    (package
+      (name "emacs-org-rainbow-tags")
+      (version "0.1-pre")
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/KaratasFurkan/org-rainbow-tags")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "006nx01sby8k0fc9lf63ldf0sl94ihldyrvqr9r18fb1gpzvivl6"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/KaratasFurkan/org-rainbow-tags")
+      (synopsis
+       "Colorize org tags automatically to make them visually distinguishable")
+      (description
+       "This package adds random colors to your org tags. In order to make
+colors random but consistent between same tags, colors are generated from the
+hash of the tag names.")
+      (license license:gpl3))))
+
 (define-public emacs-org-rich-yank
   (package
     (name "emacs-org-rich-yank")