diff mbox series

[bug#59418] add raider

Message ID 20221124151505.3218-1-ahriman@fedora.email
State New
Headers show
Series [bug#59418] add raider | expand

Commit Message

Ahriman Nov. 24, 2022, 3:15 p.m. UTC
Hi,
https://github.com/ADBeveridge/raider/blob/develop/meson.build has meson_version: '>= 0.61.0'

* gnu/packages/gnome.scm (raider): New variable.
---
 gnu/packages/gnome.scm | 40 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)


base-commit: 347733bcde2edb60bc831d363971c488eb74e3f8

Comments

Christopher Baines Nov. 25, 2022, 10:53 a.m. UTC | #1
Ahriman via Guix-patches via <guix-patches@gnu.org> writes:

> Hi,
> https://github.com/ADBeveridge/raider/blob/develop/meson.build has meson_version: '>= 0.61.0'
>
> * gnu/packages/gnome.scm (raider): New variable.
> ---
>  gnu/packages/gnome.scm | 40 ++++++++++++++++++++++++++++++++++++++++
>  1 file changed, 40 insertions(+)

Thanks for the updated patch, I made some minor tweaks, in particular
wrapping with GSETTINGS_SCHEMA_DIR so that it starts when run directly
from the store (like /gnu/store/.../bin/raider) and pushed to master as
123e6f5f2422f573673a5fdce88d88014bcbe0f1.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 3d942635a2..882196a488 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4956,6 +4956,46 @@  (define-public glib-networking
 from the GSettings schemas in gsettings-desktop-schemas.")
     (license license:lgpl2.1+)))
 
+(define-public raider
+  (package
+    (name "raider")
+    (version "1.3.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/ADBeveridge/raider/")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0ll9220d6qf9m7wdi5xhq69p8h8whs7l5h5nzdhlbn99qh5388bz"))))
+    (build-system meson-build-system)
+    (arguments
+     (list #:meson meson-0.63
+           #:phases #~(modify-phases %standard-phases
+                        (add-after 'unpack 'patch-paths
+                          (lambda* (#:key inputs #:allow-other-keys)
+                            (substitute* "data/com.github.ADBeveridge.Raider.gschema.xml"
+                              (("/usr/bin/shred")
+                               (which "shred"))))))))
+    (native-inputs (list gettext-minimal
+                         pkg-config
+                         cmake
+                         `(,glib "bin")
+                         desktop-file-utils
+                         itstool
+                         gobject-introspection
+                         blueprint-compiler
+                         `(,gtk "bin")))
+    (inputs (list libadwaita
+                  gtk))
+    (home-page "https://github.com/ADBeveridge/raider")
+    (synopsis "Securely delete your files")
+    (description
+     "Raider is a simple shredding program built for GNOME.  Also known as File
+Shredder, it uses the GNU Core Utility called shred to securely delete files.")
+    (license license:gpl3+)))
+
 (define-public rest
   (package
     (name "rest")