diff mbox series

[bug#59541] Added r-rfacts package

Message ID 20221124110956.37518-1-navid.afkhami@mdc-berlin.de
State New
Headers show
Series [bug#59541] Added r-rfacts package | expand

Commit Message

nafkhamdc Nov. 24, 2022, 11:09 a.m. UTC
---
 gnu/packages/cran.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

Comments

Ricardo Wurmus Nov. 24, 2022, 4:42 p.m. UTC | #1
Hi,

looks like FACTS is nonfree software, and since r-rfacts doesn’t make
any sense to use without FACTS we cannot add this package to the
official Guix channel — even though rfacts itself is free software.

(For the record: this has been added to guix-science-nonfree instead.)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3e5d654c5a..1487af41e6 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -472,6 +472,33 @@  (define-public r-emdist
 Distance (EMD).")
     (license license:expat)))
 
+(define-public r-rfacts
+  (package
+    (name "r-rfacts")
+    (version "0.2.1")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "rfacts" version))
+              (sha256
+               (base32
+                "0h2ryyl5zc3pxi85y0qwadfz7sdzz0m6ilwzabw317sb0z5lms5b"))))
+    (properties `((upstream-name . "rfacts")))
+    (build-system r-build-system)
+    (inputs (list))
+    (propagated-inputs (list r-digest r-fs r-tibble r-xml2))
+    (native-inputs (list r-knitr))
+    (home-page "https://elilillyco.github.io/rfacts/")
+    (synopsis "Tool for invoking FACTS to run clinical trial simulations")
+    (description
+     "The rfacts package is an R interface to the Fixed and Adaptive Clinical Trial
+Simulator @code{FACTS} on Unix-like systems.
+It programmatically invokes @code{FACTS} to run clinical trial simulations.
+It aggregates simulation output data into tidy data frames.
+These capabilities provide end-to-end automation for
+large-scale simulation pipelines, and they enhance computational
+reproducibility.")
+    (license license:expat)))
+
 (define-public r-ggalt
   (package
     (name "r-ggalt")