diff mbox series

[bug#59399,1/4] gnu: Add go-github-com-nathan-osman-go-sunrise.

Message ID 20221120172402.26408-1-felix.lechner@lease-up.com
State New
Headers show
Series [bug#59399,1/4] gnu: Add go-github-com-nathan-osman-go-sunrise. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

Felix Lechner Nov. 20, 2022, 5:23 p.m. UTC
* gnu/packages/golang.scm (go-github-com-nathan-osman-go-sunrise):
  New variable.
---
 gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)


base-commit: ac09fcb955e9358c330d728693759ca1a2e20542

Comments

\( Nov. 20, 2022, 5:26 p.m. UTC | #1
Heya,

On Sun Nov 20, 2022 at 5:23 PM GMT, Felix Lechner wrote:
> * gnu/packages/golang.scm (go-github-com-nathan-osman-go-sunrise):
>   New variable.

> * gnu/packages/golang.scm (go-github-com-hebcal-gematriya):
>   New variable.

> * gnu/packages/golang.scm (go-github-com-hebcal-hebcal-go):
>   New variable.

> * gnu/packages/calendar.scm (hebcal): New variable.

All LGTM!

    -- (
Christopher Baines Nov. 24, 2022, 9:48 a.m. UTC | #2
"( via Guix-patches" via <guix-patches@gnu.org> writes:

> Heya,
>
> On Sun Nov 20, 2022 at 5:23 PM GMT, Felix Lechner wrote:
>> * gnu/packages/golang.scm (go-github-com-nathan-osman-go-sunrise):
>>   New variable.
>
>> * gnu/packages/golang.scm (go-github-com-hebcal-gematriya):
>>   New variable.
>
>> * gnu/packages/golang.scm (go-github-com-hebcal-hebcal-go):
>>   New variable.
>
>> * gnu/packages/calendar.scm (hebcal): New variable.
>
> All LGTM!
>
>     -- (

Thanks both! I've gone ahead and pushed these patches to master as
963e86af87216e8c1f4967e8047e8de415bb1000.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index b3df51ed5f..78443b81a5 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2485,6 +2485,32 @@  (define-public go-gopkg-in-go-playground-validator-v9
 @end itemize")
     (license license:expat)))
 
+(define-public go-github-com-nathan-osman-go-sunrise
+  (let ((commit "c8f9f1eb869135f07378e7e3c5ec7a005f806c73")
+        (revision "0"))
+    (package
+      (name "go-github-com-nathan-osman-go-sunrise")
+      (version (git-version "1.1.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/nathan-osman/go-sunrise")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "017zwzx05r5spxcs07dp6bnh7waknzsd819k7aqd8kr819v3x9in"))))
+      (build-system go-build-system)
+      (arguments
+       (list #:import-path "github.com/nathan-osman/go-sunrise"))
+      (home-page "https://github.com/nathan-osman/go-sunrise")
+      (synopsis "Calculate sunrise and sunset times in Go")
+      (description
+       "This package provides a Go library for calculating sunrise and
+sunset times from geographical coordinates and a date.")
+      (license license:expat))))
+
 (define-public go-github-com-aws-sdk
   (package
     (name "go-github-com-aws-sdk")