diff mbox series

[bug#59386] gnu: Add vulkan-memory-allocator.

Message ID 20221120134931.9084-1-i@dan.games
State New
Headers show
Series [bug#59386] gnu: Add vulkan-memory-allocator. | expand

Checks

Context Check Description
cbaines/applying patch fail
cbaines/issue success View issue
cbaines/applying patch fail
cbaines/issue success View issue
cbaines/applying patch fail
cbaines/issue success View issue

Commit Message

dan Nov. 20, 2022, 1:49 p.m. UTC
* gnu/packages/vulkan.scm (vulkan-memory-allocator): New variable.
---
 gnu/packages/vulkan.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Comments

Marius Bakke Nov. 20, 2022, 4:25 p.m. UTC | #1
dan <i@dan.games> skriver:

> * gnu/packages/vulkan.scm (vulkan-memory-allocator): New variable.

Applied, thanks!

I added a (file-name ...) field to the source and reindented to shorten
line lengths.

Great job on the description.  :-)

Pushed as cae97cd773befcc68ce0ba8709e50c8697b7f0d3.
diff mbox series

Patch

diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index 95b8542133..cbad4f3abc 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -5,6 +5,7 @@ 
 ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2021 Mathieu Othacehe <othacehe@gnu.org>
 ;;; Copyright © 2022 Kaelyn Takata <kaelyn.alexi@protonmail.com>
+;;; Copyright © 2022 dan <i@dan.games>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -502,3 +503,30 @@  (define-public volk
 skipping loader dispatch overhead.")
     (home-page "https://github.com/zeux/volk")
     (license license:expat)))
+
+(define-public vulkan-memory-allocator
+  (package
+    (name "vulkan-memory-allocator")
+    (version "3.0.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url
+                     "https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator")
+                    (commit (string-append "v" version))))
+              (sha256
+               (base32
+                "1hpzjwl5bgqv9hmf1fdldihfllcbdg515f391a200klg0rnixdds"))))
+    (build-system cmake-build-system)
+    (arguments
+     ;; no test
+     `(#:tests? #f))
+    (inputs (list vulkan-loader vulkan-headers))
+    (synopsis "Vulkan memory allocation library")
+    (description
+     "The Vulkan Memory Allocator (VMA) library provides a simple and easy to
+integrate API to help users allocate memory for Vulkan buffer and image
+storage.")
+    (home-page
+     "https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator")
+    (license license:expat)))